iPhoto at Startup

Discussion in 'macOS' started by slabman, Apr 27, 2009.

  1. slabman macrumors member

    Joined:
    Jan 13, 2008
    Location:
    Plano TX
    #1
    Why does iPhoto load everytime at startup? I've looked at everything including preferences and the startup folder, but can't find how to not have it start up automatically. BTW...this began when I moved my iPhoto files to an external hard drive.
     
  2. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #2
    have you looked inside Accounts in System Preferences (or right click on iPhoto and see if "Open at Login" is ticked)?

    if so, do you have an iPhone? in Image Capture preferences choose "No application" under Camera.
     
  3. mrbrightside623 macrumors regular

    Joined:
    Mar 21, 2009
    Location:
    San Jose, CA
    #3
    I remember reading this somewhere before but don't know exactly how to do it but I will give it a try. This happens when I connect my iphone. Since your external HD has photos it is I guess considered like a camera. Go To IPhoto preferences and in the general tab... go to bottom one labeled Connecting Camera Opens:(IPhoto?) <--- change that to no application and see how that works.

    -Tony

    Edit: Richthomas' suggestion is good too. I forgot to mention it about the open at login tick as well. But yea check the iphoto preference about the camera connection.
     
  4. slabman thread starter macrumors member

    Joined:
    Jan 13, 2008
    Location:
    Plano TX
    #4
    What both of you are saying makes very good sense, so I did change the "startup at connection" preference under the "general" tab and it works! I knew it had to be something like that but couldn't find the right tab. Now I guess I have to launch iPhoto myself to download photos, but no biggie. Thanks again, guys. :D
     
  5. mrbrightside623 macrumors regular

    Joined:
    Mar 21, 2009
    Location:
    San Jose, CA
    #5
    Glad To Hear It Has Worked Out For You ^_^.

    -Tony
     

Share This Page