iPhoto 'can't open Photo Library' error...

Discussion in 'Mac Basics and Help' started by dylanbrown, Aug 14, 2011.

  1. dylanbrown macrumors 6502

    Joined:
    Aug 20, 2008
    Location:
    London
    #1
    Hi there,

    Before obtaining the 10.7 Lion Upgrade I backed-up my system using Time Machine and started fresh with a copy of 10.6 before installing the 10.7 update and transferring over my old files and applications.

    Unfortunately, iPhoto now displays an error when it opens stating that "You can't open your Photo Library using this version of iPhoto". It also says that I've made changes using a newer version of iPhoto and I should use the latest version of iPhoto, however, the Photo Library would only have been opened on 10.6 under the most recent version available at the time, I then upgraded to Lion, installed & updated iPhoto from my original install DVD's and tried to open the Photo Library using the latest version but to no avail.

    I have tried re-installing iLife from the Application Install DVD's again but the error still displays. I have also tried using an old iPhoto Library from my Time Machine backup several months ago, again to no success.

    Any help would be greatly appreciated!
     
  2. Porty99 macrumors newbie

    Joined:
    Aug 31, 2011
    #2
    iPhoto library update problem

    I have a very similar problem.

    I am using an iMac running OS 10.6.8.

    When launching iPhoto 7.1.5 it gives a message saying you need to update your library.

    I click update and the update starts. I get a progress bar that continually tells me 4 minutes left and after the first few minutes of this the spinning beach ball of death. The progress bar still looks like it is trying to update. However, the force quit windows says iPhoto is not responding. I reload iPhoto from an earlier time machine copy when it was working and the same error occurs.

    If anyone has an idea of a work around it would be greatly appreciated. I don't really want to buy another version if iPhoto.

    Thanks
     

Share This Page