Iphoto corrupt pics?

Discussion in 'Mac Apps and Mac App Store' started by zaika, May 31, 2008.

  1. zaika macrumors newbie

    Joined:
    May 31, 2008
    #1
    I have Iphoto 5.0.4 and it had been working fine ever since we got our powerbook in 2003. Two rolls ago, I imported some vacation pics of my kids, then went through them and deleted those that I didn't like.
    A week later, I wanted to look at them again and found "grey boxes" instead of pics thumbnails. Iphoto freezes everytime I try to open them, the colorful wheel keeps on spinning for a while.
    I tried to Iphoto library folder to open them but a box comes up and says that's it's corrupted or not recogniazable format. It also shows on the description that it's 0kb but when I open iphoto and manage to click on the pic/grey box and it shows the regular file size.

    Can anybody help me fix, or recover those pics as they're great memories or our family vacation? I would really appreciate it. BTW, I tried rebuilding the library but it didn't work. Please help me.
     
  2. skybolt macrumors 6502a

    Joined:
    Feb 20, 2005
    Location:
    Nashville, TN, USA
    #2
    Did you try the full manual rebuild as described at the lower portion of this: http://docs.info.apple.com/article.html?artnum=107947? You may get duplicates, but if it brings back your lost photos it would be worth it.

    When you deleted them, where were you? Did you delete from the app or from the library in finder? You should always do anything and everything from within the app itself and stay out of the finder. Did you look in the trash?
     

Share This Page