iPhoto crash after migration

Discussion in 'Mac Apps and Mac App Store' started by benjaminrosen, Jun 2, 2010.

  1. benjaminrosen macrumors newbie

    Joined:
    Jun 2, 2010
    #1
    I recently used Migration Assistant to bring user data/documents from my iBook G3/10.3.9/iPhoto 2.0, to my iBook G4/10.4.11/iPhoto 7.1

    Upon launching iPhoto 7.1 with the recently migrated photos, the app spent some time updating and (I assume) reorganizing the photos ...and then it crashed.

    The application crashes every time I attempt to load it. I've since deleted all the old photos (they are backed up on the old computer), deleted every associated pref I could find, to no avail. note, iPhoto opens no problem with my other user account.

    I would simply reinstall, but, of course, my iLife cd is inaccessible at the moment (deep, deep storage).

    Crash log:

    Date/Time: 2010-06-02 22:17:44.918 -0400
    OS Version: 10.4.11 (Build 8S165)
    Report Version: 4

    Command: iPhoto
    Path: /Applications/iPhoto.app/Contents/MacOS/iPhoto
    Parent: WindowServer [411]

    Version: 7.1 (7.1)
    Build Version: 9
    Project Name: iPhotoProject
    Source Version: 3470000

    PID: 442
    Thread: 8

    Exception: EXC_BREAKPOINT (0x0006)
    Code[0]: 0x00000001
    Code[1]: 0x92c11490

    Any help would be appreciated thx!!!
     
  2. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #2
    It is likely a iPhoto Library-specific issue. Launch iPhoto with the option key held down, when given the option to create a new library, do so. iPhoto is more than likely going to open up at that point, but of course with no images in the newly created library.

    iPhoto cannot upgrade a 5-version old library, so if you want the images from the old computer to be displayed in the new version of iPhoto you are going to want to export out all the rolls/pictures and then email or use some other means to transport the resulting jpegs to the newer iBook and then import to iPhoto 7.1.
     
  3. benjaminrosen thread starter macrumors newbie

    Joined:
    Jun 2, 2010
    #3
    Since my last post, here's what I've done:

    I deleted the user account that I had migrated, and I RE-migrated all the info. I installed an iPhoto update (7.1.4). I moved photos out of my picture folder to my desktop. holding down option key, I launched iPhoto, and chose to create new, empty library. It crashed. (reminder, iPhoto works fine with other user accounts.) this leads me to conclude, somehow, migration assistant is corrupting iphoto...

    any new ideas/suggestions?
     

Share This Page