Iphoto Crashes On Import?? URGENT!

Discussion in 'Mac Apps and Mac App Store' started by heyryanleys, Apr 25, 2012.

  1. heyryanleys macrumors newbie

    Joined:
    Mar 21, 2012
    #1
    Hey guys!

    So I have a really big presentation that I have to do tomorrow and I spent months taking pictures but now iphoto refuses to import them! All I need to do is import them into an event and then I was planning on using the slideshow option and just letting it do it's thing.

    This is really important to me so if anyone has any help it would be greatly appreciated! I've probably read every thing on the internet about iphoto crashing in the previous two days trying to figure out how to get it to work.

    Not sure if it helps but I accidentally removed my memory card unsafely from the card reader a few days ago, could that be it? My photos won't import into aperture either!

    I tried to post my crash log but it said that it's too many characters. Would that help anyone? I'd be willing to email it or something!

    THANK YOU!
     
  2. LaWally macrumors 6502a

    Joined:
    Feb 24, 2012
    #2
    Well clearly I'm hoping for your sake that you have already imported the bulk of your photos for this project and these are the last of them. Otherwise you might have learned a very hard lesson.

    I don't like that your photos do not import into aperture either. That might mean a corrupted SD card.

    I have never used an SD card, but I'm assuming that it mounts on the desktop like a USB drive when inserted into your Mac. Does it? Can you open the mounted card and view your photos? Did you try copying the photos to another folder on your Mac and import them from there?

    When you try to import does iPhoto crash immediately or does it import one or more photos? If none, maybe the first photo is corrupted?

    Just thinking out loud, don't know if any of this is a help or not.
     
  3. heyryanleys thread starter macrumors newbie

    Joined:
    Mar 21, 2012
    #3
    Thanks for the response! I already took the photos off of my memory card and saved them in a folder in my documents. Even from here I can not import the photos. I've tried downloading photos off the web, and finding old photos on my computer i hadn't imported to import into iphoto and iphoto still won't accept them.

    When I try to import into iphoto all that happens is it says "Importing photos" then the blue and white loading bar stops, and iphoto crashes. It does not import any photos.
     
  4. LaWally macrumors 6502a

    Joined:
    Feb 24, 2012
    #4
    Have you ever been able to import into iPhoto? If so, have you tried restoring all the iPhoto Library Files back to that point in time? Or have you tried removing the /Library/Application Support/3ivx folder, which some have said fixed the problem for them?

    I know you said you tried everything about iPhoto crashing that you were able to find on the net, but thought I'd ask anyway.
     
  5. heyryanleys thread starter macrumors newbie

    Joined:
    Mar 21, 2012
    #5
    Yeah, iPhoto and I have had a great relationship in the past. I looked for the 3ivx but I can't find it anywhere. I wish I had it!! Everyone says they just get rid of it and BAM, it works.
     

Share This Page