iPhoto crashing after 9.2.1 update

Discussion in 'Mac Apps and Mac App Store' started by BluInSpace, Nov 6, 2011.

  1. BluInSpace macrumors newbie

    Joined:
    Mar 11, 2009
    Location:
    London
    #1
    Hi all,

    Installed the iPhoto 9.2.1 update this morning and iPhoto now crashes on opening with the following error:

    "iPhoto cannot be opened because of a Problem.

    Check with the developer to make sure iPhoto works with this version of Mac OS X. You may need to reinstall the application. Be sure to Install any Availableupdates for the application and Mac OS X."

    Running OSX 10.7.2 and previously iPhoto was patched up to date.

    Has anyone else encountered the error or a solution?

    Full error log is:

    Process: iPhoto [549]
    Path: /Applications/iPhoto.app/Contents/MacOS/iPhoto
    Identifier: com.apple.iPhoto
    Version: 9.2.1 (9.2.1)
    Build Info: iPhotoProject-628000000000000~3
    Code Type: X86 (Native)
    Parent Process: launchd [217]

    Date/Time: 2011-11-06 11:13:23.921 +0000
    OS Version: Mac OS X 10.7.2 (11C74)
    Report Version: 9

    Interval Since Last Report: 2269 sec
    Crashes Since Last Report: 4
    Per-App Crashes Since Last Report: 4
    Anonymous UUID: F101407F-F5FF-4CA7-9E4C-0545DEAA254A

    Crashed Thread: 0

    Exception Type: EXC_BREAKPOINT (SIGTRAP)
    Exception Codes: 0x0000000000000002, 0x0000000000000000

    Application Specific Information:
    dyld: launch, loading dependent libraries

    Dyld Error Message:
    Library not loaded: /Library/Frameworks/iLifeFaceRecognition.framework/Versions/A/iLifeFaceRecognition
    Referenced from: /Applications/iPhoto.app/Contents/MacOS/iPhoto
    Reason: image not found

    Binary Images:
    0x1000 - 0xd1afeb com.apple.iPhoto (9.2.1 - 9.2.1) <68601E93-E4CF-3B4C-AFFD-4781A92DD58B> /Applications/iPhoto.app/Contents/MacOS/iPhoto
    0xe83000 - 0xf63fe7 org.python.python (2.6.7 - 2.6.7) <61DBA92A-C39A-3A52-86F2-59CF9D310CB4> /System/Library/Frameworks/Python.framework/Versions/2.6/Python
    0xfae000 - 0x114effb com.apple.geode (1.5 - 151.51) <28D29759-F356-3608-B9CF-3031F3299B1B> /Applications/iPhoto.app/Contents/Frameworks/Geode.framework/Versions/A/Geode
    0x11ee000 - 0x11f0fff com.apple.iLifePhotoStreamConfiguration (2.2 - 2.2) <4FA61CE9-1718-3E07-9896-0023A2A49699> /Applications/iPhoto.app/Contents/Frameworks/iLifePhotoStreamConfiguration.framework/Versions/A/iLifePhotoStreamConfiguration
    0x11f6000 - 0x1205fff com.apple.iLifeAssetManagement (2.0 - 2.33) <8346DE35-5F86-3338-9913-B035B3EE5435> /Applications/iPhoto.app/Contents/Frameworks/iLifeAssetManagement.framework/Versions/A/iLifeAssetManagement
    0x1212000 - 0x123affb com.apple.iPhoto.Tessera (1.1 - 60.10) <7BA9184E-0A00-3083-8322-772ECBDD30C9> /Applications/iPhoto.app/Contents/Frameworks/Tessera.framework/Versions/A/Tessera
    0x124b000 - 0x1272ffb com.apple.iPhoto.Tellus (1.3 - 60.10) <4AABB0BC-AC97-3EE4-BF0F-D8499DDB57C0> /Applications/iPhoto.app/Contents/Frameworks/Tellus.framework/Versions/A/Tellus
    0x1287000 - 0x1291fff com.apple.iphoto.AccountConfigurationPlugin (1.2 - 1.2) <3B68F126-D783-3F86-AF04-A0F6A459BE67> /Applications/iPhoto.app/Contents/Frameworks/AccountConfigurationPlugin.framework/Versions/A/AccountConfigurationPlugin
    0x8fea5000 - 0x8fed79c7 dyld (195.5 - ???) <134323A7-49DC-3A9D-ACFD-32FAD0FD6BA2> /usr/lib/dyld

    Model: MacBookPro5,2, BootROM MBP52.008E.B05, 2 processors, Intel Core 2 Duo, 2.93 GHz, 8 GB, SMC 1.42f4
    Graphics: NVIDIA GeForce 9600M GT, NVIDIA GeForce 9600M GT, PCIe, 512 MB
    Graphics: NVIDIA GeForce 9400M, NVIDIA GeForce 9400M, PCI, 256 MB
    Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1067 MHz, 0x802C, 0x31364A53463531323634485A2D3147314431
    Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1067 MHz, 0x802C, 0x31364A53463531323634485A2D3147314431
    AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x8D), Broadcom BCM43xx 1.0 (5.100.98.75.18)
    Bluetooth: Version 4.0.1f4, 2 service, 11 devices, 1 incoming serial ports
    Network Service: Ethernet, Ethernet, en0
    Network Service: AirPort, AirPort, en1
    Serial ATA Device: Hitachi HTS723232L9SA62, 320.07 GB
    Serial ATA Device: MATSHITADVD-R UJ-868
    USB Device: Built-in iSight, apple_vendor_id, 0x8507, 0x24400000 / 2
    USB Device: Apple Internal Keyboard / Trackpad, apple_vendor_id, 0x0237, 0x04600000 / 3
    USB Device: IR Receiver, apple_vendor_id, 0x8242, 0x04500000 / 2
    USB Device: BRCM2046 Hub, 0x0a5c (Broadcom Corp.), 0x4500, 0x06100000 / 2
    USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x8217, 0x06110000 / 3
     
  2. johnhw macrumors 6502

    Joined:
    Jun 16, 2009
    #2
    I guess you installed a corrupt update. Try repairing permissions, if it still doesn't work I guess you'll have to re-install iPhoto (if you got the disk).
     
  3. BluInSpace thread starter macrumors newbie

    Joined:
    Mar 11, 2009
    Location:
    London
    #3
    I've gone to the Apple site and downloaded the update directly (as opposed to 1st install via the auto update prompt upon opening iPhoto) and still get the same issue.... :(

    What makes you think permissions may be an issue?
     
  4. valexa macrumors member

    Joined:
    Nov 3, 2007
    #4
  5. lang679 macrumors newbie

    Joined:
    Mar 13, 2009
    #5
    iPhoto crash

    The same has happened to me.

    I just updated iPhoto today and I'm using OS 10.6.8. Now iphoto doesn't open at all and I don't have the reinstall disk or access to an Apple store because I'm studying abroad.

    Any other way to reinstall iPhoto? Or can I uninstall the update? Or anything?

    I can't find my iphoto library to copy those docs either. I use time machine but I'm not sure what it updates or where it saves what it does.

    I just want my photos back!
     
  6. cannondale1974 macrumors newbie

    Joined:
    Jul 4, 2011
    Location:
    Lexington, Ky.
    #6
    I'm in the same boat as you lang. Anyone have any ideas?
     
  7. whawhat macrumors 6502

    Joined:
    Jun 9, 2006
    #7
    Just updated to 9.2.2 hoping it would fix all the crashing when plugging in my iPhone but no luck. Any news on what's causing this and is there a fix yet? Thanks.
     

Share This Page