iphoto crashing on import from USB- Help!

Discussion in 'Mac Basics and Help' started by Imac Shawn, Nov 30, 2008.

  1. Imac Shawn macrumors newbie

    Joined:
    Jun 18, 2002
    #1
    Hey Everyone,

    I'm having a frustrating problem with my Alu iMac 2.8/4g/750. About half of the time I import photos into iphoto, my entire machine locks up. It always happens in the same manner: first iphoto, then the rest of the machine freezes. The mouse cursor still works, and things like video that was playing before the import started will keep going, but I can't kill anything or access the terminal. I thought that the problem was my card reader, an off-brand, but it does the same thing when importing from the camera, a Canon 350D. I'm importing RAWs. I've tried repairing permissions and deleting the iphoto plist file, but nothing helps. I'm considering re-installing the system, do you think that would help? Thanks a lot in advance for your help!
     
  2. Imac Shawn thread starter macrumors newbie

    Joined:
    Jun 18, 2002
    #2
    Forgot!

    I forgot to mention, running the latest version of iphoto, '08.
     
  3. NickEm009 macrumors newbie

    Joined:
    Feb 14, 2007
    Location:
    Macintosh Portable
    #3
    Try restarting the computer,and with no other applications running, then open iPhoto first and then connect the camera to your Mac. If that doesn't work you can try quiting iPhoto and plugging the camera into the Mac, then it should show up as a storage device. If it does try dragging the folder from the camera to your desktop. Good Luck!:apple:
     
  4. Imac Shawn thread starter macrumors newbie

    Joined:
    Jun 18, 2002
    #4
    reinstalling the OS?

    Thanks for the advice, Nick, I appreciate it. I'd really like to find a permanent fix, though, I'm sure this isn't normal behavior for iphoto. Does anyone think that a system reinstall would help?
     
  5. plinden macrumors 68040

    plinden

    Joined:
    Apr 8, 2004
    #5
    Try copying the files off the card on the hard drive, then importing into iPhoto. You'll have a better idea of where the problem is then. If the copy causes your Mac to freeze, then you'll know it's not iPhoto, and if it freezes at importing into iPhoto, you'll know that's the problem.

    I would also try creating a new account and importing into iPhoto from there (it'll have a brand new shiny preferences file). If that works fine, move your iPhoto preferences file on your original account to another location (just to keep a copy of it, rather than deleting it) and restart iPhoto.

    If you're still having problems, I would also try reinstalling iPhoto before an OS reinstall.
     
  6. Imac Shawn thread starter macrumors newbie

    Joined:
    Jun 18, 2002
    #6
    Reinstalling iphoto

    Thanks Plinden - I tried deleting iphoto plist, and it seemed better for about a week, but then it came back. That's what makes this problem so frustrating, it works for a while then acts up. I've thought that I fixed it at least three times now! I think I'll try reinstalling iphoto - What is the best way to delete the old copy? Do I need to use spotlight to delete everything pertaining to iphoto except the library? Should I start a new library and reimport everything from my old library, or should I try running the fresh install with the old library?
     
  7. Imac Shawn thread starter macrumors newbie

    Joined:
    Jun 18, 2002
    #7
    Arrghh!

    I deleted and reinstalled iphoto and deleted the plist file, but it didn't help. It locks up from either a camera or card reader import. It seems to work ok importing from image capture and then into iphoto - Any suggestions?
     
  8. Imac Shawn thread starter macrumors newbie

    Joined:
    Jun 18, 2002
    #8
    Other Ideas?

    Does anyone have any other ideas, I nave no idea what to try next except reinstalling the system, which I really don't want to do!
     

Share This Page