iPhoto crashing on launch

Discussion in 'Mac Apps and Mac App Store' started by chainprayer, Dec 26, 2008.

  1. chainprayer macrumors 6502a

    Joined:
    Feb 10, 2008
    #1
    My wife's computer (PowerBook G4) won't load iPhoto. It gets to the "loading photos" screen, then promptly crashes. I have run permission repair but everything was perfect.

    I get this error report...

    Code:
    Process:         iPhoto [280]
    Path:            /Applications/iPhoto.app/Contents/MacOS/iPhoto
    Identifier:      com.apple.iPhoto
    Version:         5.0.4 (5.0.4)
    Build Info:      iPhotoProject-2630000~8
    Code Type:       PPC (Native)
    Parent Process:  launchd [117]
    
    Date/Time:       2008-12-26 14:10:37.360 -0700
    OS Version:      Mac OS X 10.5.6 (9G55)
    Report Version:  6
    
    Exception Type:  EXC_BAD_ACCESS (SIGSEGV)
    Exception Codes: KERN_INVALID_ADDRESS at 0x000000000ffdd000
    Crashed Thread:  0
    
     
  2. ziggyonice macrumors 68020

    ziggyonice

    Joined:
    Mar 12, 2006
    Location:
    Rural America
    #2
    Are there any other user accounts on the machine?

    If there aren't, try creating another user account (System Preferences > Accounts) and log into it. Open iPhoto on that account and see if it'll open. If it does, then that narrows down the possibilities to determine the problem is something in her account, not with the computer.
     
  3. chainprayer thread starter macrumors 6502a

    Joined:
    Feb 10, 2008
    #3
    I created a second account to test iPhoto. It launches fine from the second account. :(
     
  4. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #4
    try opening iPhoto while holding option and command and then choosing "Rebuild the iPhoto Library database" and "Examine and repair iPhoto Library file permissions".
     

Share This Page