iPhoto crashing

Discussion in 'Mac Apps and Mac App Store' started by grimfool, Jul 21, 2012.

  1. grimfool macrumors member

    Joined:
    Nov 5, 2011
    #1
    since the last update I have found that iPhoto crashes on my Mac mini. It doesn't on my Macbook Pro nor my Macbook Air. It was also showing a lot of pictures distorted. After searching on the internet I decided to restore an old copy of the application from my time machine. However in the process it stopped when I selected 'replace existing copy' and said that I should check the application info and ensure that all items that I was restoring were unlocked. Since it was only the iPhoto application I checked that and it was 'not locked'
    I then tried restoring the old copy and leaving the existing one there but after doing so both copies crashed on startup. I have now deleted both copies and reinstalled iPhoto from iLife 11. The application updated OK with the latest update but it still crashes on startup.
    Does anyone have any advice on what to do now?:confused:
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    You might try rebuilding the iPhoto library by following this.
     
  3. ScottNWDW macrumors 65816

    ScottNWDW

    Joined:
    Jul 10, 2008
    Location:
    Orlando, Florida
    #3
    Ever since the last update, whenever I start iPhoto my MacBook Pro (2011) slows t a crawl. It never used to do this until the last update. after iPhoto is launched pressing any key gives me the rotating beach ball.
     
  4. grimfool thread starter macrumors member

    Joined:
    Nov 5, 2011
    #4
    I tried to do that but it crashes straight away even though I hold down the option & command keys as I start it up :(
     
  5. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #5
    Have either of you tried opening iPhoto holding just the option key and creating a new iPhoto library?

    @grimfool: Generally you should be removing iPhoto and all of the support files before reinstalling. In addition to the application there are support files in /Library/Application Supprt/iPhoto and possibly /Library/Receipts
     
  6. grimfool thread starter macrumors member

    Joined:
    Nov 5, 2011
    #6
    I did a complete restore from my time machine using a back up from a few days ago followed by a rebuild of the thumbnails and it appears to be OK now:)
     

Share This Page