iPhoto - Doesn't Open .mov files?

Discussion in 'Mac Apps and Mac App Store' started by InvalidUserID, Aug 31, 2009.

  1. InvalidUserID macrumors 6502a

    InvalidUserID

    Joined:
    Sep 7, 2008
    Location:
    Palo Alto, CA
    #1
    Didn't it used to be able to? Just double click a .mov file and it would open?

    Tried to double-click some .mov files, doesn't open. Copy and paste to desktop and open from there, it works.

    Eh?
     
  2. mark2288 macrumors regular

    Joined:
    Jan 11, 2006
    #2
    I thought when you open a movie on iPhoto it launches QuickTime to play it. Is QuickTime installed and working on your computer?
     
  3. InvalidUserID thread starter macrumors 6502a

    InvalidUserID

    Joined:
    Sep 7, 2008
    Location:
    Palo Alto, CA
    #3
    Yes, QuickTime (10.0) is installed and plays movies fine.

    I just upgraded to SL, if that makes any difference. I think maybe the update in QuickTime Player might have something to do with it?
     
  4. Tearabite macrumors regular

    Tearabite

    Joined:
    Sep 10, 2009
    Location:
    So.California
    #4
    The exact same thing happened to me when i did my SL upgrade. Were you able to find a fix?
     
  5. devburke Guest

    Joined:
    Oct 16, 2008
    #5
    I have iPhoto ’08, and since upgrading to SL, it no longer does anything when I try to open videos from iPhoto. I think it’s just an incompatibility that will likely never get fixed, as Apple’s moved onto ’09 and probably ’10.
     
  6. liquidsuns macrumors 6502

    Joined:
    Jun 23, 2009
    #6
    See if you have an update to iPhoto. I installed SL on a new hdd and then installed iLife/iPhoto 09 and the movies wouldn't play. I'd double click them and nothing would happen. Then I searched for software updates and there was a bunch of them, as was expected, and iPhoto started playing them fine. Quicktime pops up and plays the movies.
     
  7. devburke Guest

    Joined:
    Oct 16, 2008
    #7
    I guess this just proves that the fix isn’t coming for ’08.
     
  8. Tearabite macrumors regular

    Tearabite

    Joined:
    Sep 10, 2009
    Location:
    So.California
    #8
    Turns out that QTPlayer 7 was not installed (not in the Utlities folder).. Went through the SL Optional Install PKG, added QT7, and now .MOV files play fine from iPhoto 08 .. :D
     
  9. saabsonic macrumors newbie

    Joined:
    Dec 14, 2008
    Location:
    SF Bay Area (Forestville)
    #9
    iPhoto not opening .mov files...

    Thanks to Tearabite for this solution...

    Since installing SL iPhoto wouldn't open movies taken with my iPhone. I just used the Optional Installs to re-install QT7 and all is well again!
     

Share This Page