iPhoto Doesn't Work

Discussion in 'Mac Apps and Mac App Store' started by BonBonxx, Jul 28, 2012.

  1. BonBonxx macrumors newbie

    Joined:
    Jul 28, 2012
    #1
    I've had a Mac for 19 months now and my iPhoto doesn't work. When ever I open it, it says:
    "Your photo library is either in use by another application or has become unreadable - Shut down and restart your computer, and then open iPhoto again. If the problem persists, try rebuilding your photo library. To do this, quit iPhoto, and then reopen it while keeping the Option and Command keys pressed. You can also try restoring your photo library from a backup."

    I've tried doing all of that but it doesn't work. My laptop is from school and I can't exactly take it to Apple (School rules, have to do it their way). Is there any way to fix it?
     
  2. jjhoekstra macrumors regular

    Joined:
    Apr 23, 2009
    #2
    Reinstall iPhoto and than reinstall your photo's from your backup.
     
  3. Dave Braine macrumors 68040

    Dave Braine

    Joined:
    Mar 19, 2008
    Location:
    Warrington, UK
    #3
    If you've never managed to use iPhoto, and don't have any pictures in it, then try deleting the iPhoto Library file from your Pictures folder. iPhoto will just make a new one next time you open it.
     
  4. rtroiani macrumors newbie

    Joined:
    Jun 17, 2009
    Location:
    Henryville, PA
    #4
    Fix iPhoto

    I had the same issue (in use by another program or corrupt...). I downloaded iPhoto Library Manager from FatCatSoftware and it worked. Looks like you can use the trial version. It created a new library and moved all of my photos over to the new library leaving the old untouched. I had thousands of photos along with photos that go along with a book I'm writing, so it was critical to get some of these back.
     
  5. colourfastt macrumors 6502a

    colourfastt

    Joined:
    Apr 7, 2009
    #5
    Since you stated it's a "school laptop", it's possible the app is locked down.
     

Share This Page