iPhoto error Message Everytime I open!

Discussion in 'Mac Apps and Mac App Store' started by mrsmitty13, May 29, 2008.

  1. mrsmitty13 macrumors newbie

    Joined:
    Aug 17, 2007
    #1
    I just purchased my second mac (iMac 24" screen) which has finally made me free from windows. So one of my first things I did was put my 10 year 30,000 photo collection into iPhoto... Everything worked fine except I'm having one problem.... Apparently there were 15 files that were messed up and didn't get imported. Thats fine and no big deal, I can do without them. The problem is EVERYTIME I open iPhoto I get the error message....

    Photos have been found in the iPhoto library that were not imported. Would you like to import them?

    This has a yes or no question.... If I say yes, iphoto will create an "album" that is empty with no photos entitled "recovered photos" and give me the error message....

    Unreadable Files
    The following files could not be imported (they may be an unrecognized file type or the files may not contain valid data)


    If I choose NO, then iPhoto will give me this message....

    The photos have been placed in the folder /Users/ks72/Pictures/iPhoto Library Recovered Photos_3.

    I'm find with trashing these photos and you think after iPhoto placed them in the folder it would stop but it happens EVERYTIME I open iPhoto... I found one thing online somewhere that was partially relevant and it said "go into your iphoto library and find the actual data files which might be difficult due to the naming system and delete them" but how do I go INTO the iphoto library. Everytime I go in my pictures folder and click on the iPhoto library it will just open iPhoto....

    Please advise!!! Thank You!

    I am using the latest versions of leopard and iphoto.
     
  2. mrsmitty13 thread starter macrumors newbie

    Joined:
    Aug 17, 2007
  3. rontheancient macrumors regular

    Joined:
    Nov 22, 2005
    Location:
    USA
    #3
    I have the exact same problem and just found a solution:

    Go to the Pictures folder in your home folder.

    Right-click (or Control-Click) "iPhoto Library" and choose "Show Package Contents".

    Move whatever is inside the "Import" folder to another place on your Mac, probably your desktop for easy access.

    These photos (assuming you want to keep them), are locked and you will need to unlock them via Get Info. Then if you want them in your library, reimport them in. If you dont want them, just Secure Empty Trash it.

    Good Luck.
     
  4. forinh macrumors newbie

    Joined:
    Jun 23, 2009
    #4
    Ron
    Thanks for posting that information, I was getting frustrated opening iphoto and getting all those empty folders. Helped a newbie regain confidence in the purchase.
     
  5. foggch macrumors newbie

    Joined:
    Jul 8, 2009
    #5
    iphoto did something to my files-extremely unusual

    I connected my iphone one day and the thing said "no access privileges" or something along those lines. I realized at that point I could not open iphoto. The same thing, no access privileges. I tried a bunch of things to get it to relauch, rebuilding iphoto etc. Sometimes it would load but when I closed iphoto on the next launch I'd get the same problem. I eventually tried to just create a new iphoto library. I was successful and thought I'd just grab the files from the iphoto package contents. Well...none of the 8891 photos I have in my library will import. I get this error:

    *The following files could not be imported (they may be an unrecognized file type or the files may not contain valid data)*

    I spent about 6 hours over 2 days trying to get to the bottom of this. I eventually called apple tech support and $49 bucks and over an hour later the guy says "at this point we've determined that iphoto is working properly and that it has to do with the content and therefore it is not there problem anymore"! Thanks for the 49 bucks! In their opinion I must have done something to the files so they wont import. Which by the way is total b.s. These files load into any other program fine. Somehow, iphoto f'ed up and these photo's must have some sort of protection embedded in them exclusive to iphoto. What the hell? I'm not an iphoto expert and I've been hung out to dry.

    Anyone else out there ever have this problem. All new photos or I should say any photos not previously loaded into iphoto will load no problem.

    F
     
  6. samiam70 macrumors newbie

    Joined:
    Feb 3, 2010
    #6
    Help iphoto won't open either!!

    My ibook G4 has an issue with iphoto. Whenever I try to open iphoto it comes up with a message that says: "Your Thumbnails need to be Upgraded", it goes on to say that this version of iphoto has new upgrades, do you want to upgrade now, will take a few minutes to upgrade library. Asks to do it now or later. I push either button and it thinks for a minute tries to open then shuts down iphoto. Then I get an error message that says it had quit the application send message to APPLE. Please help!!! I have tried repairing disk permissions and have searched everywhere shrot of taking it in to the store. Thanks.:(
     

Share This Page