iPhoto freezes whenever I click "show more faces"

Discussion in 'Mac Apps and Mac App Store' started by 3alaawi, Jun 11, 2012.

  1. 3alaawi macrumors newbie

    Joined:
    Sep 19, 2011
    Location:
    UK
    #1
    Hello! I'm almost certain this hasn't been asked before as I did quite a lot of research.

    Short story is, everytime I click "show more faces" in iPhoto faces screen I get the rainbow loading cursor and the app freezes for 10 seconds, this problem wasn't present earlier, my mac (2010 model, bought new in 2011) runs pretty smooth and I keep it clean with about 70gb free space and few programs running.

    The long story goes like this: I recently went through my 10,000 photo library putting names to all the faces on there and things went find all the way to completion. I didn't know I could tell iPhoto to "ignore" certain faces by clicking the "x" at the confirm faces screen, so I just labelled them all under a fake name called XX. Anyway, when I was all done, I wanted to delete this fake XX and have iPhoto ignore it all. So I deleted XX, and all the XX photos went back to the faces screen (where I'd have to name them/ignore them all over again). So as I set myself to click all the little "x"s in the corner to make iPhoto ignore these unwanted faces, everytime I click show more faces (its only 3 faces on the screen at one time), iPhoto freezes for like 10 seconds and I get that rainbow swirly wirly thing (where the cursor turns into a rainbow coloured circle thing). Now 10 seconds isnt a lot, but it is when I have 2100 faces to go through (thats 700 pages into 10 seconds). Also, the problem wasn't there when I did all the other faces so there's got to be something. I'm usually fairly good at googling my way through any problems I get with computers, but couldn't find any clues with this one. Any ideas?:confused:

    Might be useful:
    iphoto 9.2.3
    photo library size 45.93gb (10,273 items)
    mac os x lion 10.7.4
    macbook pro 4gb ram, 2.4 core 2 duo

    Thanks,
    Ali
     
  2. 3alaawi thread starter macrumors newbie

    Joined:
    Sep 19, 2011
    Location:
    UK
    #2
    Update: I've tried rebuilding the library. repairing the library, thumbnails and all the other options you get when you Opt Cmd open iPhoto. The only change now is that when I click "show more faces" the first time it quickly gives me a new set of faces to confirm, but from there on it goes slow with that 10 second loading rainbow. If I click on another area say "events" and back to "faces", again, the first page turn is quick, and the rest have that same loading problem. I'm confused!
     
  3. 3alaawi thread starter macrumors newbie

    Joined:
    Sep 19, 2011
    Location:
    UK
    #3
    For anyone who's out there reading this, the new aperture and iphoto updates let you access each others libraries. So I just did the faces in aperture which didn't have any lag and was a quicker system for updating faces too. As for the lag problem, I exported my library to aperture so I don't have an iphoto library anymore, but I tried setting faces on iphoto of my aperture library and it worked fine without any problems. So, problem solved and not solved :D
     

Share This Page