iPhoto, Image Capture Can't see iPhone Pics-UPDATED

Discussion in 'iOS 5 and earlier' started by Firefly1013, Oct 18, 2011.

  1. Firefly1013, Oct 18, 2011
    Last edited: Oct 20, 2011

    Firefly1013 macrumors newbie

    Firefly1013

    Joined:
    Oct 18, 2011
    #1
    Neither does Preview's import function. ALL three see my iPhone 4, but tell me I have no photos on it (I have 22 photos I can see just fine on the phone). I'm running OSX 10.6.8 on my Macbook and have iPhoto 11-- I've done all the latest updates, tried trashing the plist files for Image Capture and iPhoto... nothing. Very frustrating! It worked just fine prior to the iOS 5 upgrade on my phone. Can anybody help? :confused:
     
  2. Firefly1013 thread starter macrumors newbie

    Firefly1013

    Joined:
    Oct 18, 2011
    #2
    Yikes, if no one else is having this issue, now I'm really worried!

    I'm thinking that I have three options at this point: 1)restore my phone through iTunes as a "New Device" and see if that works. I hate to lose all my data though, and have to re-install all my apps etc. 2) Upgrade to Lion and see if that fixes the issue. 3) Wait. Is it possible this connectivity issue will be fixed with future updates? I suppose I could also try and find different photo importing software, but I really would rather not.

    Would love to hear some advice about this!
     
  3. Firefly1013 thread starter macrumors newbie

    Firefly1013

    Joined:
    Oct 18, 2011
    #3
    Thought I would post my solution here in case it helps anyone else. Turns out it was a corrupt picture file, which I was only able to see with the Phone View app. I tried many different ways to delete the file off the phone, with no success. So, I did a restore to factory settings through iTunes, then loaded my calendars, contacts, music etc back onto the phone. It seems to have solved the issue.
     
  4. xcell macrumors newbie

    Joined:
    Aug 18, 2005
    #4
    IMPORT ERROR
    Same problem with me: Image Capture detects my iPhone (3GS) and the pictures on it (althought without preview) but the picts can't be imported (f.e. to Desktop) - which was possible before I upgraded to iOS 5...
     
  5. wbthreenames macrumors newbie

    Joined:
    Dec 3, 2011
    #5
    same problem with a large photoroll

    Hello, Similar problem, but with an entire photoroll of 1000 photos. I should delete a few anyway, but the issue of iphoto, and image capture not seeing the images is there, same as yours.

    This includes photos that I had previously imported to iphoto, so its not corrupt files, viewed in image capture so it is not a checked 'hide images already imported' box in iphoto. I can email photo's from iphoto and open them in mail and elsewhere.
    I get a dotted line around a square instead of a thumbnail.

    Am trying software restore and hoping the backup will contain the hidden images...
     
  6. wbthreenames macrumors newbie

    Joined:
    Dec 3, 2011
    #6
    iphone photos

    no joy. The restore hasn't made them visible. I'm going to email myself the latest photos that haven't been uploaded before the problem started and then delete the photoroll.
     
  7. wbthreenames macrumors newbie

    Joined:
    Dec 3, 2011
    #7
    a solution

    After emailing myself all the photo's that hadn't imported and deleting them from within the iPhone, in iPhoto I unmounted the iphone; after disconnecting it it was still showing so I gave it a right click to unmount.

    In Image Capture> Browse Devices I unchecked iphone connected.

    Then I reconnected and the undownloaded, undeleted photos popped up.

    Whether it was deleting a corrupted file or just the disconnecting of the phantom iPhone I don't know. But it seems to work okay now.
     
  8. adityashah1989 macrumors 6502

    Joined:
    Dec 11, 2008
    #8
    Image capture is detecting my iPhone 4S but its not showing any of my 2000+ pictures on my iPhone! How do I import? I'm using Mountain Lion.
     
  9. imom macrumors regular

    imom

    Joined:
    Feb 20, 2008
    #9
    There is no "browse devices" option!
    Anyone know how to fix this?
     
  10. ETERNA-Z macrumors newbie

    Joined:
    Dec 28, 2006
    #10
    Try a different computer....

    Had this problem on my iPhone 4 and mavericks. Took it to a different machine I use and dropbox actually asked me right away to import images, so i did. No problems. I never checked to see if other apps saw them too, but I would bet they would.
     
  11. Howard Brazee macrumors 6502

    Howard Brazee

    Joined:
    Oct 24, 2006
    Location:
    Lafayette CO
    #11
    For me, Image Capture can see that there are JEPG files, with names such as img_1433, but they are videos that I accidentally create. (I used to take lots more pictures before something changed and I keep getting videos - I think my finger must touch stuff I can't see without glasses and only get real photos half of the time). I can open my camera and see them there, but can't see them on my Mac. I can delete them with image capture on my phone, but can't with my wife's (I think that has something to do with having her pictures on iCloud). (Boy I hate editing my posts with Chrome , when I hit delete, the cursor jumps around).
     
  12. lizzard9 macrumors newbie

    Joined:
    Jun 24, 2017
    #12
    I know this is old thread, but I've had the exact issue on iPhone 6 with iOS 10.3.2. I tried different Macs to no joy. iCloud doesn't let you download all photos, only one by one!

    I've connected to a Windows PC and was able to access all my photos. Hope this helps.
     
  13. subd macrumors newbie

    Joined:
    Jan 12, 2009
    #13
    In case this helps anyone, I had a very similar problem. Image capture would recognise the iphone 5s, but wouldn't see any images.

    By accident I discovered this method:
    iPhone is plugged into computer and ImageCapture open. iphone is recognised by name but ImageCapture shows no photos.

    On iPhone I go to Settings > General > Name
    And here I change the name.

    As soon as I did the photos appeared in ImageCapture.

    I hope this helps someone
     
  14. pcal macrumors newbie

    Joined:
    Aug 10, 2017
    #14
    Wow, that did work. Thanks! Must be some corruption on the laptop, then.
     
  15. Poindextrous macrumors newbie

    Joined:
    Aug 15, 2017
    #15
    Thank you so much.

    Wow. Eight years later and the same solution works!

    C'mon Apple...



     

Share This Page