iPhoto & Image Capture won't unlock iPhone...

Discussion in 'iOS 10' started by ti22Seven, Oct 9, 2016.

  1. ti22Seven macrumors newbie

    Joined:
    Dec 3, 2012
    #1
    Hello -

    I've upgraded my iPhone6 to 10.0.2 and my macBook Pro to Sierra 10.12 and i am having an issue - perhaps somebody can share some insight...

    Plug iPhone and iTunes starts right up. No issues there. Itunes is 12.5.1.21.

    Now the issue:

    If I start ImageCapture on the mac, the first thing it does is say "Please unlock iPhone". I have to manually unlock the iPhone and then pictures show up as usual.
    If I start iPhoto on the mac, it just sits there with a message "Loading...". Nothing else. If I manually unlock the iPhone all works just fine.

    What I have done so far:
    • I forced the whole "trust this computer" thing. That was an interesting exercise - did not help.
    • I then disabled all Restrictions (Settings/General/Restrictions) - did not help.
    • Last ditch effort: disabled passcode. This deleted all iPay settings as well as others which is not good. Tried ti run ImageCapture and iPhoto and they worked fine. But this is not an option. The second I turned this back on, same problem.
    Any suggestions? This has NEVER happened before except now, after the upgrade. I know, why complain about having to manually unlock the iPhone. Well I rather not have to do that especially when the thing is wired with the USB cord to my mac.

    Finally, I tried the exact things above with my iPad Air2 and it did the exact same thing. So this is a IOS10 issue. Any help would be appreciated.
     
  2. ti22Seven thread starter macrumors newbie

    Joined:
    Dec 3, 2012
  3. simon lefisch macrumors 6502a

    simon lefisch

    Joined:
    Sep 29, 2014
    #3
    Care to share what you did so others that have that prob who come across this thread can see the solution?
     
  4. joedec, Oct 15, 2016
    Last edited: Oct 15, 2016

    joedec macrumors 6502

    joedec

    Joined:
    Jul 25, 2014
    Location:
    Cupertino
    #4
    I would certainly like to have the solution, I've yet to resolve this problem.
     
  5. akisurane macrumors newbie

    Joined:
    Nov 21, 2017
    #5
    Hi, just now I experienced this and found out that simply taking the password off from the iPhone will do the trick.
    It did work for me like a charm but not certain it will repeat to do for anyone else in that matter.
    Hope this will help
    someway!
    someday!
     
  6. karthikchandrasekhar2 macrumors newbie

    karthikchandrasekhar2

    Joined:
    Apr 26, 2017
    #6
    Try to disconnect the USB cable from the Mac. Quit the Image Capture app. Now reconnect the cable and open the Image Capture and wait for it to say unlock the iPhone. Once you unlock, choose "Trust this ?computer" on the iPhone and you should be able to see your iPhone photos on your image capture.

    Hope this helps
     
  7. MikeQue macrumors newbie

    Joined:
    Nov 7, 2011
    #7
    Been stuck with the same. I tried switching cables and trying both USB ports on my Macbook, and that seemed to finally solve this problem.
     

Share This Page