iPhoto Import Problem - edit: problem solved

Discussion in 'Mac Apps and Mac App Store' started by wagg34, Dec 31, 2007.

  1. wagg34 macrumors newbie

    Joined:
    Dec 6, 2007
    #1
    Hello. I am the proud new owner of a 24" iMac (2.4ghz, refurbished, OS X 10.5, fully Software Updated). I am very happy with it, and have had almost no problems. Unfortunately, there is one, and for me it's pretty big (a big reason I chose a Mac was for photography purposes).

    All of my pictures when I was using Windows were on an external hard drive. When I got my Mac, I took the hard drive downstairs to it, plugged it in, and transferred all the pics onto the Mac's HD. No problems; worked fine.

    Now though, when I try to import them into iPhoto, it gets the the very end (which takes quite a while with so many pictures), and says "Finishing Import", but gets stuck there with the bar half-way. There is no choice but to "Force Quit", and then no photos at all are imported.

    I've tried with smaller numbers of files; single folders; single files - same problem. When searching and reading about the problem, I first found that it may be related to RAW files, so I took all of them out, an tried again - same problem. The only other possible cause I've found (which is actually quite likely) has to do with the fact that I had imported all my photos into Lightroom and added keywords/tagging when they were on my PC. If this is the problem though, I can't seem to find a solution.

    Does anyone know anything else I could try? I would really like to use iPhoto, as it was quite a large factor in my purchase. Any help would be appreciated.

    EDIT: I have found a workaround solution to the problem. Thanks.
     
  2. skybolt macrumors 6502a

    Joined:
    Feb 20, 2005
    Location:
    Nashville, TN, USA
    #2
    How about sharing with us how you resolved the issue so we can all learn?

    Thanks!
     
  3. wagg34 thread starter macrumors newbie

    Joined:
    Dec 6, 2007
    #3
    Well, it turns out that it did have something to do with Lightroom. I'm not sure what exactly, but apparently photos edited in Lightroom add a specific kind of metadata. So I had to use another program (the homepage for ExifTool, which was recommended wasn't working, so I used Graphic Converter) to remove the specific metadata (XMP) from all my pictures (...took quite a while *sigh*). Note: It does keep all the "normal" metadata stuff, so don't worry about losing dates or camera settings, etc.

    Obviously, it's far from a perfect solution, but until Apple and/or Adobe fixes it, it might help someone else here.

    My experience with iPhoto since "fixing" it have been great though, and I really enjoy using it. :D It's a beautiful program once you can actually get pictures onto it!
     

Share This Page