iphoto issues

Discussion in 'Mac Apps and Mac App Store' started by chimpboy74, Dec 22, 2014.

  1. chimpboy74 macrumors 6502a

    chimpboy74

    Joined:
    Nov 12, 2007
    Location:
    Scotland
    #1
    Hi
    Hoping someone can help as I'm getting to end of tether.
    I have an old mac mini which I updated to Yosemite a few Weeks ago. A couple of days ago my iphoto said the library needed updated which I clicked on but it seemed to hang so I force quit. However i restarted the mini and opened iphoto but it opened like it was new. No photos

    i Checked and the iphoto library still existed (and judging by side it's complete. 200gb) however it wouldn't let me reimport it. Thankfully I have time machine but when I go back. Regardless of date the restore button is greyed out and I can't go back.

    So I tried the alt and command whilst opening and asked to repair the library. Which seemed to work. However it said 140k pics to be imported. Finally 101k did import but only in 2 events. Fine, i selected them and asked to autosplit. After several hours it completed but it's a mess. A lot of the photos are triplicated. Photos are in wrong events entirely and some of the photos appear to be "faces" type images. Ie zoomed in close on a face.

    Also I'm missing 30k images/videos (got a message saying 3k images couldn't import (most appeared to be video files)
    My whole iphoto library is now a mess and I have no idea How to fix it.

    Can anyone make any suggestions. Even if it is to sort time machine so I can roll back a week.

    Hope you can help.
     
  2. ApfelKuchen macrumors 68020

    Joined:
    Aug 28, 2012
    Location:
    Between the coasts
    #2
    It sounds like you now have two Libraries - one is empty, the other is the original 200 GB library. A simple Spotlight search for "iPhoto Library" will tell you how many libraries you have.

    Why are you trying to Import a library? Import is meant for importing photos into a library. Have you tried: File menu > Switch to Library...?
     
  3. chimpboy74 thread starter macrumors 6502a

    chimpboy74

    Joined:
    Nov 12, 2007
    Location:
    Scotland
    #3
    I tried import cos when iphoto opened empty it said to connect camera or import files. As I knew the ok fart was still there I tried it. But it didn't work anyway it was under one of the repair options it all went pear shaped.
    .I'll try your suggestion and report back.
     
  4. chimpboy74 thread starter macrumors 6502a

    chimpboy74

    Joined:
    Nov 12, 2007
    Location:
    Scotland
    #4
    Ok. So I Checked. I only have one iphoto library however have three additional folders
    Iphoto library recovered photos
    Iphoto library recovered photos_2
    Iphoto library recovered photos_3


    Each seem to contain a lot of files. (taking forever to calculate size)

    Seems to me the easiest thing would be to roll back time machine but it won't let me!!!!
     
  5. chimpboy74 thread starter macrumors 6502a

    chimpboy74

    Joined:
    Nov 12, 2007
    Location:
    Scotland
    #5
    Ok so getting back to this after Xmas. I managed to roll back via time machine so I have only one iPhoto library

    However when I open iPhoto it acts like its New with no photos. No matter what I do it won't read the library I have.

    I got to a point where it tried to repair but it just hung and eventually crashed my Mac.
     

Share This Page