iPhoto library not opening

Discussion in 'Mac Apps and Mac App Store' started by thinkmark, Oct 26, 2008.

  1. thinkmark macrumors newbie

    Joined:
    Sep 30, 2008
    #1
    iPhoto opens, its fine as far as i can see.
    The problem is that my iPhoto library, the 72GB beast sitting happily in my Time Capsule containing over 22'000 images will not show up in the app.
    I have never had this problem before, and have been in my current iPhoto/iTunes Time Capsule set up since september, with no problems.

    What can i do to get my precious memories back, as starting again just is not an option, unless your Hiro Nakamura... (From Heroes)

    I have deleted the Com.apple.iphoto.plist files from /library/preferences
    I have tried to rebuild my library but iPhoto doesn't seem to acknowledge it.

    What can i do, i am freaking out!:eek::confused::confused:
     
  2. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #2
    Is the iPhoto Library part of the backup database or is it just stored on the same partition as the backup? If you can open up the package of the library by right-clicking (or control-clicking) you can copy out the Originals and Modified folders to your desktop or another location. You can then manually rebuild the library from one or both of these folders by reimporting them into a new library package. This should allow you to recover the photos but will not save the album data or your slideshows/books/etc. Take a look at http://support.apple.com/kb/HT2638 if you haven't already tried.
     

Share This Page