iphoto lost my photo library

Discussion in 'Mac Apps and Mac App Store' started by Patrick Bateman, Jun 11, 2005.

  1. Patrick Bateman macrumors member

    Sep 10, 2003
    After starting iphoto up yesterday, poof! All gone. I didn't have that much to back up so no BIG loss but it still pisses me off. Many (most) of the photos are still under "pictures" and the library and different folders are still there but some are corrupted and must have changed somehow. Tried to import anything to iphoto but it's unable to take any of them though most of the them are viewable on Preview. I've already reinstalled OSX 10.3.9 and did the disk utility a few times. What else can I try?
    Also, safari crashes whenever I come to macrumors so I'm using Firefox. :confused:
  2. mac-er macrumors 65816

    Apr 9, 2003
    First try repairing permissions.

    (Use Disk Utility to do this, which is in the Utilities folder)
  3. Diatribe macrumors 601


    Jan 8, 2004
    Back in the motherland
    If that doesn't help, try deleting the preference lists for iPhoto and Safari.

  4. toneloco2881 macrumors 6502

    Jan 23, 2005
    If that doesn't help try rebuilding the library by holding down the option key while starting iphoto. It will then ask you for the location of your existing library. Hope that helps.
  5. Patrick Bateman thread starter macrumors member

    Sep 10, 2003
    I don't know what the deal is (iphoto 2.0.1) but I've tried to do that option or shift command or whatever other combinations while starting iphoto and never get anything asking me about rebuilding the library. Any clues?

Share This Page