iphoto missing photos after ML upgrade

Discussion in 'Mac Apps and Mac App Store' started by syringa, May 2, 2013.

  1. syringa macrumors newbie

    Joined:
    May 2, 2013
    #1
    My iphoto library is completely messed up after a Mountain Lion upgrade last week. There are greyed out placeholders in events with roll number titles but no photos, my entire event and face organisation has vanished and been replaced by seemingly random groupings. Any editing I have ever made on any photo is gone. I have 67GB of photolibrary so every time I try anything it takes forever.
    I have tried a number of fixes - restoring previous libraries from Time Capsule but same effect. As soon as I try to open Iphoto with any previous library I get messages saying ..."needs to be upgrade to work with this version of iphoto. Photo library will not be readable by previous versions after upgrade." "the library has issues that require rebuilding to correct" and finally after okaying the previous 2 messages I get " Warning: an inconsistency in your database has been detected. App will quit relaunch and restore your database to a consistent state."

    Anyone else had a similar issue after ML upgrade?
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    Try this... command-q to quit iPhoto. Then hold the command and option keys both down when relaunch iPhoto. You will get a window as shown below. Select the first option then click repair. If that does not fix it, repeat and check the second option. Then the third and forth options if you need to.

    [​IMG]

    Also, do a command-r boot to recovery and start Disk Utility from the recovery screen then do a repair disk on Macintosh HD.
     
  3. syringa thread starter macrumors newbie

    Joined:
    May 2, 2013
    #3
    Thanks but I've tried all 4 of those options on the Current library after upgrade and on subsequent TC older library imports. Same recurring issues.
     

Share This Page