iPhoto not opening library

Discussion in 'Mac Basics and Help' started by Naimfan, Apr 3, 2011.

  1. Naimfan macrumors 68040

    Naimfan

    Joined:
    Jan 15, 2003
    #1
    All--

    I recently moved from a 13" to a 15" MBP. It's a Core 2 Duo 2.4 GHz with 8 GB RAM and a 500 GB HD. I used Migration Assistant to move all my data over from my Time Machine backup.

    Here's the problem: iPhoto does not open my iPhoto library. iPhoto opens, but then I get the spinning gear and no pictures come up. I let it run for an hour and change one time and had no luck. I tried deleting the iPhoto library and restoring from the Time Machine backup, but get the same thing.

    I'm going to get an iLife 11 pack today and I'll try reinstalling, but would be grateful for any other suggestions.
     
  2. Dave Braine macrumors 68040

    Dave Braine

    Joined:
    Mar 19, 2008
    Location:
    Warrington, UK
    #2
    Try opening iPhoto with the Option/Alt key held down. It will ask you to choose a Library. Navigate to yours and see if it opens.
     
  3. Naimfan thread starter macrumors 68040

    Naimfan

    Joined:
    Jan 15, 2003
    #3
    Thanks. Tried that, didn't help. All my pictures appear in "All Images," but iPhoto doesn't use them. I think I have a corrupted picture or two . . .
     

Share This Page