iphoto not responding when importing digital camera videos

Discussion in 'Mac Basics and Help' started by okrelayer, Sep 1, 2008.

  1. okrelayer macrumors 6502a

    Joined:
    May 25, 2008
    #1
    Hello guys. Maybe you can help? My digital camera imports pictures fine.. even short videos. But i have a 5 min video and it seems iphoto keeps not responding when importing it? Anyone know why?

    It took quite awhile for the video to import on my fathers windows pc, but it imported. Maybe im not giving it enough time? either way when i option/command/esc it shows iPhoto as not responding.
     
  2. okrelayer thread starter macrumors 6502a

    Joined:
    May 25, 2008
    #2
    sorry guys! i actually gave it some time, and it worked lmao.

    i have ZERO patients!
     
  3. swiftaw macrumors 603

    swiftaw

    Joined:
    Jan 31, 2005
    Location:
    Omaha, NE, USA
    #3
    Well, you wouldn't, unless you were a Doctor. :)
     
  4. okrelayer thread starter macrumors 6502a

    Joined:
    May 25, 2008
  5. beatbabe macrumors newbie

    Joined:
    Oct 16, 2008
    #5
    Im having the same problem!

    Is there any other way of importing digital camera vids without going through iPhoto?

    Ive removed my preferences file and move the albums xml file to desktop but no luck.

    It says loading, but the progress bar doesnt change even tho the lights are flashing on my camera and then it goes to iphoto and there is nothing there.

    So frustrating!
     
  6. beatbabe macrumors newbie

    Joined:
    Oct 16, 2008
    #6
    never mind, i found out you can import using Image Capture in the Applications folder and that worked fine :)
     

Share This Page