iPhoto on 5.0.1?

Discussion in 'iPad Hacks' started by porcupine8, Mar 8, 2012.

  1. porcupine8 macrumors 6502a

    Joined:
    Mar 2, 2011
    #1
    Anyone have any ideas on how to get around the app store's requirement of 5.1 for iPhoto? Or will I just have to wait til 5.1 is jailbroken to give it a whirl?
     
  2. Dan14 macrumors regular

    Joined:
    Aug 28, 2009
    #2
    Unfortunately so...
     
  3. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #3
    You can change your reported system version in the /System/Library/CoreServices/SystemVersion.plist then reboot. But it may require 5.1 API's that are not in 5.0.1 and it could crash your device when launched. If it does, just remove it. Don't other to change your system version back or your could have problems.
     
  4. swordfish5736 macrumors 68000

    swordfish5736

    Joined:
    Jun 29, 2007
    Location:
    Cesspool
    #4
    there is a tweak in cydia called iphoto501fix from the sound of it its not perfect. You must download iphoto first then install the tweak. I havent really messed with it yet but it opened and loaded my library
     
  5. Miao Ying, Mar 14, 2012
    Last edited: Mar 14, 2012

    Miao Ying macrumors member

    Joined:
    Aug 17, 2010
    #5
    How does that work when it won't let you download it due to the fact you're not on 5.1?

    Sounds like you'd have to go through acquiring it another way.. Edit: Found tweak, nm
     
  6. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #6
    Install with the the system version change, after install change it back and install cydia tweak
     
  7. swordfish5736 macrumors 68000

    swordfish5736

    Joined:
    Jun 29, 2007
    Location:
    Cesspool
    #7
    I believe the apple configuration tool will allow you to push it to the iPad if you download on your computer.

    This works for getting it on an iPad 1. As if you try to from the app store on the device it won't because it's not supported
     
  8. phi7588 macrumors member

    Joined:
    Sep 11, 2009
    #8
    is the iPhoto worth the risk of having a restore? With the current tweak (which I haven't tried yet) does it works flawlessly?
     
  9. Maverik3 macrumors 6502

    Joined:
    Mar 13, 2012
    Location:
    Meridian Idaho
    #9
    I just downloaded it and i played around with it for a bit and I found no problems at all, using iPad 2 16gb 5.0.1:apple:
     
  10. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #10
    Installed iPhoto and iphoto501fix. Seems to work fine. I tried out all the tools and effects with no crashes and expected results. The one problem is that it takes forever (several minutes) to update the library -- which it does any time an image is added to the library. I don't know if this is an issue with iPhoto in general, or just on 5.0.1.

    One more thing: so far when I have deleted images from my photostream in iPhoto they have not actually been deleted from photo stream. I'm not sure if I'm doing something wrong, or what. Perhaps it relies on a system call that is not present in 5.0.1? If so, it seems to be the only feature that doesn't work.
     

Share This Page