iPhoto photostream in Yosemite does not function?

Discussion in 'OS X Yosemite (10.10)' started by shoorty0690, Oct 8, 2014.

  1. shoorty0690 macrumors member

    Joined:
    Jul 5, 2009
    #1
    Maybe I missed this, but when I installed Yosemite on my computer, photo stream stopped working in iPhoto. I try to click enable through the app and the app slows down to a crawl and then times out and crashes. And after I quit out or it quits out by itself, I could no longer open the iPhoto library. It would crash iPhoto upon opening. I eventually had to take the master folder out of the library file and create a new library. Anyone else having this issue or problem?


    Ryan
     
  2. MEJHarrison macrumors 6502a

    Joined:
    Feb 2, 2009
    #2
    I use Aperture. I had the same issue initially. It wouldn't download from PhotoStream. Started it again later and it asked if I wanted to connect. Since then things have been running as expected.
     
  3. shoorty0690 thread starter macrumors member

    Joined:
    Jul 5, 2009
    #3
    I tried Aperture as well and it did the same thing. Slowed down and froze. I eventually removed Aperature and iPhoto from my system and redownloaded it. It still did not work. When I go to the iCloud option on the left hand side in iPhoto is has the screen to enable or cancel iCloud photo stream and when I click enable, it starts to load up with a loading box at the top, but then just stop and stays on the screen. The application just goes to a crawl and freezes until it crashes. Then I can no longer open the iPhoto library without crashing upon opening.
     
  4. MEJHarrison macrumors 6502a

    Joined:
    Feb 2, 2009
    #4
    Odd. My Aperture is fine. Although I did notice last night that it forgot about my iCloud settings. Had to set that up again to download my latest photos. And I'll probably need to do it again down the road. But at least it's working.
     
  5. shoorty0690 thread starter macrumors member

    Joined:
    Jul 5, 2009
    #5
    Yea its so weird. I even tried Aperature again just a few days ago. Even with a new library. Turn on Photostream and it freezes and crashes. It's frustrating. I loved not having to plug in my phone to back up photos.
     
  6. shoorty0690 thread starter macrumors member

    Joined:
    Jul 5, 2009
    #6
    I have some good news. After yesterdays update in iPhoto, Photostream is up and running again.
     

Share This Page