iPhoto problem

Discussion in 'Mac Apps and Mac App Store' started by olg, Mar 23, 2008.

  1. olg macrumors newbie

    Joined:
    Dec 13, 2007
    #1
    Hi everyone,

    I've had my iMac for about 7 months now and have used iPhoto to import all my pictures from my Canon point and shoot camera. Recently on my last import, I received an "Unreadable Files" message. I haven't changed the settings on the camera and figured I hadn't formatted the card in a while, so perhaps it was an error with the card.

    Well, I recently upgraded to a Nikon DSLR camera. I formatted a new SD card I got with the camera and have shot a few photos (60 to be exact). I wanted to import the pictures to e-mail out, and I again get the same "Unreadable Files" message. It also says the files my be an unrecognized file type or the files may not contain valid data. I know for a fact that the both cameras shot a .jpg file (I'm not experienced enough to use RAW), and I never had the problems until about 2 weeks ago.

    I have the latest version of iPhoto 7.1.3, so I'm not sure of the issue. Has anyone else experienced this lately?
     
  2. Doolinguy macrumors newbie

    Joined:
    Jun 14, 2008
    #2
    I have a similar problem.

    I just got a Nikon D300 and started shooting in RAW format and I got the unreadable error after I switched. It imported fine as a JPEG file from earlier shoots.

    I've got a MacBook Pro, running OS 10.4.1 yet and use iPhoto version 6.

    Do I need to upgrade my OS and/or iPhoto, get Aperture to import RAW files or is it a setting on my Camera?

    Thanks for any help.

    David
     
  3. olg thread starter macrumors newbie

    Joined:
    Dec 13, 2007
    #3
    Hi David,

    I managed to fix it and I forgot to update my post when I did. The only thing I could find online said: 1) It probably was a photo, which I know it was if I shot it myself with a digital camera or 2)My hard disk was getting full (I have over 250 gb available today, and at the time was probably closer to 260 gb).

    I think I repaired my disk permissions from Disk Utility and then tried to import again. I say think because I did not write down once I fixed it and it was something I remember thinking was too simple that it couldn't be all I have to do to get this to work.

    I'm running Leopard, and I personally don't think it's an upgrade OS issue for you, however, I've only been a mac user for less than 1 year.

    Hope this helps you out. If I can think of exactly what I did, I'll post again so that anyone can read what worked (for me anyways).
     

Share This Page