iPhoto Problems - The Volume for JPG Cannot be Found

Discussion in 'Mac Basics and Help' started by pammyspyce, Jan 9, 2009.

  1. pammyspyce macrumors regular


    Jul 29, 2005
    Bay Area, Calif
    I'm having an iPhoto issue.

    I have over 17,000 photos in iPhoto. One particular, recent batch keeps having an error.

    The thumbnails for the 82 photos are always visible. When I double click on one the photos I get an error that says: "The volume for "xxxxxx.JPG" cannot be found." It's specific to one event or batch of 82 photos. The photos and events prior and after are fine.

    I've restored the pictures from the SD card and the pictures will work like normal in iPhoto.... for a few hours and then I start getting the same error.

    Same with Time Machine. I even went back 9 days (which is as far back as I'm willing to go back since I've uploaded pictures that I don't have back-ups for past that). Again, I'll restore iPhoto, the batch of 82 photos will act normally, as in I can see the thumbnail and then double click on it to get the bigger image and then suddenly I'll get the error again.

    I'm attaching a picture of the error.

    I'm lost. Any help? Please?

    Attached Files:

  2. BlueRevolution macrumors 603


    Jul 26, 2004
    Montreal, QC
    Does it only work when you have the camera plugged in?
  3. pammyspyce thread starter macrumors regular


    Jul 29, 2005
    Bay Area, Calif
    I just thought I'd follow up with the solution in case anyone else does a search for this problem.

    Somehow in the advance preferences, I unchecked the option of copying photos to the iPhoto library. Everytime I "restored" my photos, be it from Time Machine or my SD card, they would work... as long as my SD card was in the reader or TM didn't do a new back-up.

    I searched the Apple Help boards and figured out my problem. I rechecked the box, deleted the "bad" photos and then re-imported them. Viola. Problem solved. The photos are back in my library perfectly.

    Here's a picture of the box you need to check, just for reference.

    Attached Files:

  4. yakflyer macrumors newbie

    Mar 3, 2009
    Ha! You can't believe how pleased I am to read this, as I have been going through the nightmare of not being able to use many of my pics for several weeks. But tell me, how did you re-import the pics? From Time Machine? Or where? I have over 10,000 of them on iPhoto, many of them corrupted in this way. I no longer have any originals outside iPhoto. Would be glad to get this issue sorted once and for all :)
  5. Kiwigavin macrumors newbie

    Mar 7, 2009
    Ooh ooh, me too, me too.

    Ok it's only a dozen or so and the originals are long gone from the external drive but any ideas on how to restore them would be gratefully received.
  6. lkmac macrumors newbie

    Apr 6, 2009
    same problem!

    I have tons of pictures that are nowhere other than in iPhoto--- help! almost all of them now give me that error message. I can't access anything!
  7. Tumbleweed666 macrumors 68000


    Mar 20, 2009
    Near London, UK.
    Isn't the issue here that the photos aren't in iPhoto, just the thumbnails? Do you have that same option for copying unchecked? Did you have a lot of photos on an external drive which is no more? Or maybe just rearranged a folder or folders where they were?
  8. tjosal macrumors newbie

    Dec 1, 2009
    Had the same problem when I made a CD of a photo album to transfer to another computer.

    I'm sorry but it sure as heck seems like the default "Copy items to iPhoto library" should be YES?!
  9. tobymackenzie macrumors newbie

    Mar 25, 2010
    Peninsula, Ohio
    In the iPhoto Library, there are aliases for all of the photos stored elsewhere. You can replace the aliases with the actual photos and they will commence working fine in iPhoto. You will have to move each folder's contents individually though, which can be a pain for a lot of folders.
  10. Biz BAG macrumors newbie

    May 8, 2010
    The volume for image cannot be found

    I tried checking the boax and still when i attach the iphone and it tries to import i keep geting the same message. Any help would be appreciated
  11. maxmara2 macrumors newbie

    Jul 12, 2010
  12. bobriot macrumors member

    Feb 25, 2007
    Yeah same problem here, I can't seem to delete them as I keep getting that stupid message!!!! Reminds me of my windows days
  13. jhunterking macrumors newbie

    Nov 14, 2010
    The volume for xxxx.JPG” cannot be found.

    while searching for a solution on this forum, to the above, i accidently found one myself..but it works only randomly and i wonder if anyone can tell me why!

    those thumbnails that when clicked say 'The volume for “xxxx” cannot be found'...i then press ok, then drag the thumbnail onto my desktop.

    press done on the bottom of iphoto and then drag it back into your event and it imports just fine (if another alert box comes up, just placate it and press ok!)


    and not with all!! but every little helps!..if any one has a proper solution to this problem, please help..or is it an iphoto '08 problem?

    it seems there are two error boxes..one thats an alert and says eg

    • 'The photo 31240_10150182006600154_618145153_13122932_2301275_n.jpg” could not be opened, because the original item cannot be found.'[/B] and another that says "The volume for “SDC14127.JPG” cannot be found."Insert the disk or connect to the server volume and wait for it to appear on the desktop, then try again"
  14. Tumbleweed666 macrumors 68000


    Mar 20, 2009
    Near London, UK.
    I don't think that's even an "improper" solution, seems to me all you are doing is copying the thumbnail out and then importing the thumbnail, not the actual photo which is gone. So you just have a teeny image left, not the original.

    Maybe there is a bug which accidentally unsets the 'copy to iphoto' flag at random, or maybe people have clumsy fingers?

    In either case, they rarely seem to have backups :-(

    FWIW my 'work stream' to avoid loss of photos.

    Take card out of camera*.
    Copy entire contents to folder on external disk.
    Copy that folder to another folder, and edit there if need be.
    Copy from second folder into iPhoto.

    Time Machine backs up iPhoto locally all the time.
    Amazon S3 backs up iPhoto externally once a week.

    Do much less than this, and one day you WILL lose some photos, be it to finger trouble or a disk crash.

    * IME if you import directly to iPhoto from a memory card, it always asks you if you want to delete the pictures off the memory card when you are done. This is another disaster waiting to happen, even if you usually never click it, the one day you accidentally do will be the day that your hard disk crashes 5 minutes later.
  15. savethered macrumors newbie

    Jan 26, 2007
    Hi, I have posted the exact same problem, this recently happened from a CD download of photos, I download from CD's all the time as I don't shoot digital.
    Never had this problem before, if you get an answer I would be grateful if you could pass it on.
    Thanks, savethered.
  16. Tumbleweed666 macrumors 68000


    Mar 20, 2009
    Near London, UK.
    Did you try the solution given in post #3 ?
  17. dbontrager macrumors newbie

    Jun 28, 2012
    My problem was directly related to Mobile Me

    I noticed that the events it was having problems with were the ones I shared on Mobile Me Gallery. Since it ends in a few days, I deleted it from my accounts in iphoto prefs. And the problem has gone away for me.
  18. gymshoe macrumors newbie

    Jul 31, 2013
    I have the same problem: "The volume for “IMG_0725.JPG” cannot be found". What seems odd is that in iPhoto, even the photos which have a thumbnail but iPhoto cannot find the actual photo, still report having the same size (~1.9MB) as the photos which have a thumbnail plus the photo... Makes me wonder if the data for the photo is actually there...

Share This Page