iPhoto problems with Pentax RAW files

Discussion in 'Digital Photography' started by bawill, Aug 27, 2008.

  1. bawill macrumors newbie

    Joined:
    Aug 27, 2008
    #1
    I am having some trouble with Pentax RAW files in iPhoto on my mac. As far as I can tell, this is a problem whether I shoot in PEF or DNG. I have a Pentax K200D camera. Many of my photos end up being solid black in iPhoto. I used to have a trial version of Aperture 2, and some of the photos showed up as solid blue in that program (the same photos showed up as black in iPhoto). This is a problem that seems to be getting more frequent. The pictures show up fine when I preview them in the finder. But once they are in iPhoto, a number of them show come up as solid black. Any ideas about what may be wrong? It seems strange that the frequency of this problem seems to be increasing. It also seems weird that the pictures preview okay in the Finder but give me trouble in iPhoto. I also just opened one in the Pentax Photo Laboratory program and was able to make adjustments okay. This issue is driving me crazy. Any ideas? I would be suspect of my SDHC cards, except that I am able to see the pictures okay in Finder and in Pentax Photo Laboratory.
     
  2. eji macrumors 6502

    eji

    Joined:
    Jun 8, 2004
    Location:
    Inland Empire
    #2
    I use a K10D and I've shot in both PEF and DNG RAW. I haven't come across this problem at all.

    A couple of questions: What version of OS X are you using, and have you applied all updates?

    Are you using iPhoto '06 or '08?

    Do you have iPhoto set to automatically import the photos into your library? (The reason I ask this is because iPhoto embeds the ColorSync profile only with imported photos.)

    If you like, you can send me one of your "black" photos and I'll see how it looks on my machine next to other PEFs and DNGs in iPhoto.

    Could also be a K200 firmware bug that needs fixing. Have you checked the Pentax site for firmware upgrades?
     
  3. bawill thread starter macrumors newbie

    Joined:
    Aug 27, 2008
    #3
    I'm using:
    Mac OS X 10.5.4
    iPhoto '08

    Yes, iPhoto automatically opens when I plug in my card reader with a card in it. It imports my photo files into the iPhoto library.

    Yes, if you are willing to check it out, I would be happy to send you one of my "black" photos. How would you like me to send one?

    I am kind of suspecting that the issue may be at least one of my card readers. I may try importing some photos by plugging my camera directly into the computer with a usb cable and see if that makes any difference.
     
  4. bawill thread starter macrumors newbie

    Joined:
    Aug 27, 2008
    #4
    maybe related to AdobeRGB???

    Okay, I realized this afternoon that the problem became out of hand when I switched my camera from shooting in sRGB to shooting in AdobeRGB. I think the problem cropped up on several photos before that switch, but it was nowhere close to the issue that it has been since I switched. Are there any reasons why this switch (sRGB to AdobeRGB) would cause the problem described in my first post above?
     
  5. Macmonter macrumors regular

    Macmonter

    Joined:
    Aug 14, 2008
    Location:
    Vermont, USA
    #5
    Check out the threads in "iPhoto Corrupts Imported B/W Images" in this forum. My scanned b/w images imported to iPhoto as all black. ChrisA suggested I open "get info" when the image is selected which led to what was different about the "black" images. I eventually found a work around to the problem.

    I hope this helps to solve your problem!
     
  6. eji macrumors 6502

    eji

    Joined:
    Jun 8, 2004
    Location:
    Inland Empire
    #6
    Hmmm. It does sound like it has to do with the embedded RGB profile, which might explain the problem with grayscale images.

    bawill, do you think you've identified the cause of the problem, or did you still want to send me a photo? If you've got IM, get in touch with me that way (my various IM handles are listed in my profile) and I'll try importing one of your "black" images.
     
  7. bawill thread starter macrumors newbie

    Joined:
    Aug 27, 2008
    #7
    Link to PEF Files

    Okay, I have put a couple files up online, one that works okay in my iPhoto, and one that comes up black in my iPhoto. When I tried saving one of the files, it seemed like my computer wanted to download it as a tiff file rather than the PEF files that it is. Hopefully you all can figure out how to overcome that issue. Let me know if I can do anything else to help you to be able to download these RAW PEF files to test. Thanks for your help on this. The url is: www.brentandcheriewilson.com/Site/iPhoto_Problems.html
     

Share This Page