iPhoto refuses to open!

Discussion in 'Mac Apps and Mac App Store' started by nbusse, Nov 5, 2007.

  1. nbusse macrumors member

    nbusse

    Joined:
    Jul 13, 2007
    Location:
    boston
    #1
    I have an iMac 800mh/768 mb.
    Over the summer, it crashed, I did a long process of reinstalling everything. I was using the OSX install discs (basic tiger). Because of hardware issues, I've only pulled it up to 10.4.7 so far.
    This is the only machine that I've been using for iphoto, so any albums would've been created & saved on this computer -- pre-crash, that is!
    This is the first time I've tried opening the app since this whole ordeal, and it's giving me this message:
    "You have made changes to your photo library using a newer version of iPhoto. Please quit and use the latest version of iPhoto."
    And the only option is to quit.

    So, fair enough - I don't know what my former setup (was only running at OS10.4.6) was running as far as ilife updates. I look up my current iphoto, it's version 2.0.1. I look up version tracker and the apple website, to see what the next upgrade would've been. There is NO RECORD of an intermediary upgrade, all I'm finding is upgrades to iLife '08, this seems to be the only support offered. I'm not gonna buy their freakin' next product over just the ability to look at my photos!! Anyone know how I can do this?
    Any help appreciated......
     
  2. cyclingplatypus macrumors 6502a

    cyclingplatypus

    Joined:
    Mar 15, 2007
    Location:
    Earth
    #2
  3. nbusse thread starter macrumors member

    nbusse

    Joined:
    Jul 13, 2007
    Location:
    boston
    #3
    Wow, that download is pretty well-hidden, I never would've found it on my own. Unfortunately, it wouldn't let me install this update, it said it couldn't find the application iPhoto on this computer. ?? I see it there in my app folder, who knows?
    I don't know what's going on with this computer, something must've gone wrong when I had to reinstall the OS... maybe these app's got corrupted somehow or something... I don't know. Used to work just fine! This computer has been nothing but frustration to me.

    I ended up trashing the whole iPhoto library (which is backed up on a seperate drive), and am just rebuilding it piece by piece. It refuses to read the previous albums or any former library data, so I'm just re-importing photos in batches.
     

Share This Page