iPhoto running amok

Discussion in 'Mac Apps and Mac App Store' started by obistan, Nov 20, 2005.

  1. obistan macrumors newbie

    Nov 20, 2005
    My photos disappeared leaving only the blank drop shadows. I tried reloading photos hoping they would fill the blanks. No such luck. Now the photos keep reloading and I have 4 or 5 of some photos. When I try to click on anything in iPhoto, the colored wheel spins for about 5 minutes before allowing me access. Upon a closer look, it seems that the photos are in the blank outlines. If I want to shut down my Mac, I have to force close iPhoto.

    I have a G5 running 10.3.9.

    Many thanks for your help.
  2. DXoverDY macrumors 6502a

    Apr 19, 2005
    repair permissions. open up disk utility, then click on the harddrive, then click the "Repair Permissions" button. then start up iphoto. make sure it's closed before you do this.
  3. Applespider macrumors G4


    Jan 20, 2004
    looking through rose-tinted spectacles...
    You could also try rebuilding your iPhoto library - it sounds like the database is confused; you haven't been moving/changing any images from your iPhoto folder in the Finder have you?

    To get iPhoto to rebuild itself, you quit iPhoto, then launch it while holding down:

    * the "shift" and "option" keys (for iPhoto 4)
    * the "option" and "command" keys (for iPhoto 5).
  4. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    I reckon Applespider's technique will probably work but if not, then remove the file named com.apple.iPhoto.plist from the folder you find it in. If this does nothing to help your problem, you can put it back where it was and everything will be back to how it was before. Remember that you shouldn't move preferences files around whilst the app is running. :)
  5. obistan thread starter macrumors newbie

    Nov 20, 2005
    Your suggestion seemed to help some, but my problem is still there. I'm tempted to erase everything in iPhoto and reload all my photos which are still on my hard drive. Many thanks, Stan
  6. obistan thread starter macrumors newbie

    Nov 20, 2005
    I tried what you suggested, but it didn't work. Thanks anyway.

Share This Page