iPhoto shows imported photos as black

Discussion in 'Digital Photography' started by jojoba, Apr 27, 2012.

  1. jojoba macrumors 68000

    Joined:
    Dec 9, 2011
    #1
    Well, the title says it all. I'm importing photos from my Canon A3350 to my MBA, and about 50% of my photos are showing up black, this has happened a few times over the past week.

    Does anyone know how to fix this? It's very frustrating :mad:
     
  2. AndyR macrumors 6502a

    AndyR

    Joined:
    Dec 9, 2005
    Location:
    Auckland, New Zealand
    #2
    I've just started having this happen this week too. Happens from both my Sony NEX-5N and my wifes Panasonic DMZ-TZ10. Photos work import fine on my wifes Win7 laptop though.
     
  3. jojoba thread starter macrumors 68000

    Joined:
    Dec 9, 2011
    #3
    I've now learned from a bit of googling that rotating the images help. it's annoying, though, I don't really have time to rotate fifty percent of my photos every time I import. But at least my photos weren't lost.
     
  4. AndyR macrumors 6502a

    AndyR

    Joined:
    Dec 9, 2005
    Location:
    Auckland, New Zealand
    #4
    Rotating didn't help me, they still all stayed black. Also removing them from iphoto and clearing the iphoto trash and then reimporting didn't help.

    But, when I rebooted my MBP and tried the import again they worked fine. Weird?!?!
     
  5. jojoba thread starter macrumors 68000

    Joined:
    Dec 9, 2011
    #5
    Did you rotate them 360 degrees? I went to the edit photo page, then rotated four times, then the photo still looked black in editing mode, but when I went back to the album, the picture showed normally.

    The import function has now worked well for me the last two times.

    Weird, definitely!
     
  6. AndyR macrumors 6502a

    AndyR

    Joined:
    Dec 9, 2005
    Location:
    Auckland, New Zealand
    #6
    No I just did a rotate once. Did it for a few photos but didn't help, and neither did deleting/emptying iphoto trash/reimport.

    Reboot did solve it though for me and hasn't happened since. Bizarre!
     

Share This Page