iPhoto slideshow music issues

Discussion in 'Mac Apps and Mac App Store' started by walk, Mar 18, 2012.

  1. walk macrumors newbie

    Joined:
    Sep 27, 2009
    #1
    Hi Guys,

    This drove me up the wall most of yesterday and I still couldn't find a solution. So hopefully someone here might be able to offer some help. Basically the problem is that iPhoto can't see my iTunes library and therefore won't allow me to add my own music when making a slideshow.

    [​IMG]

    That's what I see when I open the music settings. Searching the net has trawled up more questions that answers but the closest thing to useful was this thread on the apple support boards, although that was quite old so was dealing with earlier versions of iphoto.

    I get the feeling that the problem might stem from them the fact that my itunes library is stored on an external hard drive but I still can't find a work around. I'm on OS X 10.7.3

    I've tried multiple versions of iphoto from 8 right up to 9.2.2. I've checked and repaired all permissions. I've made sure I'm opening itunes and iphoto in the correct order. I've tried creating a new itunes library on the internal hard drive, which is still unrecognizable. I've tried the trick where you remove your itunes .xml and .itl files then reimport the xml and reset things.

    None of the above have worked and I'm running out of ideas. If anyone has any input I'd be very grateful for the help.
     
  2. walk thread starter macrumors newbie

    Joined:
    Sep 27, 2009
    #2
    So I figured out a work around. Really sketchy but since I never use iphoto and this is just a one off for a relative's wedding anniversary it'll do. I found the example music file that iphoto uses as default in their ken burns slideshow and replaced it with a different song but of the same file name.
     

Share This Page