iPhoto Stopped Opening Automatically

Discussion in 'Mac Basics and Help' started by andreajoy2, Oct 17, 2009.

  1. andreajoy2 macrumors newbie

    Joined:
    Oct 17, 2009
    #1
    I have had my iMac for about three years now and suddenly a few days ago, iPhoto stopped opening automatically when I plug in my Canon camera. I've never had this issue and can't find the camera in the Source list, either. My PC (of all things!) still opens automatically and can find my photos, so I know that the cord and camera works fine. I also tested the USB port and it works with everything else.

    Did I accidentally turn off a setting in iPhoto? Everything I've looked up says that you can only set the settings for iPhoto when you first set up your computer, but I find this hard to believe.

    Thanks for your help!
     
  2. oculus42 macrumors 6502

    Joined:
    Dec 9, 2002
    Location:
    Maine
    #2
    iPhoto '09 has "Connecting camera opens:" on the first screen of the Preferences. Not sure about older versions, but I assume it's there, somewhere.

    You could also try RCDefaultApp which adds a "Default Apps" panel to System Preferences. It has a Media tab and you can select what happens when you plug in a camera or insert a DVD or Audio CD, etc.
     
  3. kfordham281 macrumors 6502

    Joined:
    Dec 4, 2007
    #3
    I'm running iPhoto 08 and in Preferences -> General there is an option that says "Connecting camera opens" and gives you a few choices. I'd check there first.
     
  4. xUKHCx Administrator emeritus

    xUKHCx

    Joined:
    Jan 15, 2006
    Location:
    The Kop
    #4
    Have you tried a restart?

    If it doesn't appear in iPhoto, try checking Image Capture which is inside the Application folder.

    You can also change the options of what happens when the device connects through there.

    Does it appear if you use a card reader?
     
  5. andreajoy2 thread starter macrumors newbie

    Joined:
    Oct 17, 2009
    #5
    Thanks for your tips! I'm using iPhoto 06 and it doesn't have that option in the Preferences box. I looked in General and the other categories.

    I also tried to open Image Capture but it says "No Image Capture Device Connected." It's like the computer stopped reading my camera entirely? Perhaps it's not an iPhoto thing. Strange.

    Yes, have tried restarting and that doesn't help, either.

    I just tried downloading the RCDefault App and it worked! Thank you so much. Baby is due any day and I gotta get to these pics! MANY THANKS!
     

Share This Page