iPhoto suddenly won't import iPhone photos

Discussion in 'Mac Apps and Mac App Store' started by jent, Dec 6, 2010.

  1. jent macrumors 6502a


    Mar 31, 2010
    I have the iPhone 4 and iPhoto '09. Every few weeks I connect my iPhone and import my camera roll photos. For some reason the photos show up when I connect my iPhone but the Import Selected and Import All buttons are grayed out. Any idea why this might be? Thanks!
  2. marouen19 macrumors newbie

    Mar 16, 2011
    Same here, with iphone 3gs...any suggestions?
  3. daniel2828 macrumors newbie

    Sep 7, 2007
    Try this...

    Quit iPhoto. Open the Activity Monitor and search for PTPCamera and quit the process. Go to System > Library > Image Capture > Devices and double-click PTPCamera to restart it. Plug in your iPhone.

    This usually works for me.
  4. DARKiLLUSiON macrumors 6502

    Sep 21, 2007
    Toronto, Canada

    Thank you so much for the suggestion!! It does the trick after googling/searching endlessly for a fix.
  5. KenCollins macrumors newbie

    Sep 15, 2012
    Worked for me too. Excellent help, thanks!!!!!
  6. awb macrumors newbie

    Nov 17, 2012
    I have an iphone 4 and running ML on my MBP. I am using iphoto 09. The solution mentioned above worked for me when my photos would not transfer from iphone to Mac. Only problem is it only worked once and then I had to reset it again.

    Is there a way to fix this so it stays fixed?

  7. awb macrumors newbie

    Nov 17, 2012
    I think I may have found the answer in another forum. The suggestion was to turn off bluetooth. I did that and the photos downloaded into itunes. Hope that keeps working.

Share This Page