iPhoto unable to connect to Photo Stream

Discussion in 'Mac Apps and Mac App Store' started by 617arg, Jul 12, 2012.

  1. 617arg macrumors 6502

    Joined:
    Mar 3, 2008
    #1
    I've searched on Google and tried a few different things but have had no luck so far, so I'm hoping someone on here can help.

    I'm on Lion and running iPhoto 11 (9.3). I have iCloud and Photo Stream running properly on an iPhone and two iPads, but can't get it to connect on my Mac at home.

    I've checked the check box in the iCloud preferences. I've tried signing out of iCloud and then back in. I've tried to go through the steps at http://helpdeskgeek.com/help-desk/photostream-keeps-turning-off-in-iphoto-fix-it/ but don't seem to have the folder iLifeAssetManagement on my machine. I also don't have the plist files listed as Method 2 in the link above.

    Any ideas anyone else can recommend?

    Thanks for your help.
     
  2. netslacker macrumors 6502

    Joined:
    Jan 21, 2008
    #2
    Did you enable Photo Stream in iPhoto?

    iPhoto -> Preferences -> Photo Stream -> Enable

    Do you also have Aperture installed? if so, is it using photo stream? if so, I believe photo stream will only use one or the other apps but not both.
     
  3. 617arg thread starter macrumors 6502

    Joined:
    Mar 3, 2008
    #3
    Yes. The message "iPhoto was unable to connect to Photo Stream" comes up when trying to enable it.
     
  4. 617arg thread starter macrumors 6502

    Joined:
    Mar 3, 2008
    #4
    Also, don't have Aperture so that wouldn't be interfering with anything.
     
  5. 617arg thread starter macrumors 6502

    Joined:
    Mar 3, 2008
    #5
    Upgraded to iPhoto 9.3.1 last night. Still have the same issue. Just bumping this up one time to see if any other help can be offered.......
     
  6. RicardoG macrumors newbie

    Joined:
    Jun 30, 2012
    #6
    Multiple logins

    FWIW I fixed mine when I realised I'd probably downloaded iPhoto using an AppleID from the App Store but logged into iCloud with a different AppleID. I deleted iPhoto and it's related files (but not the iPhoto Library) using CleanApp, entered the App Store with my usual AppleID and downloaded iPhoto again. Once the App Store, the downloaded iPhoto and iCloud logins were the same iPhoto Stream worked again.
     

Share This Page