iPhoto upload failed and now can't download either

Discussion in 'Mac Apps and Mac App Store' started by MGrobler2, Jan 1, 2012.

  1. MGrobler2 macrumors newbie

    Jan 1, 2012
    Hi guys,

    I am pretty new to the Mac operating system - Have about one week of experience now.

    With the purchase of my new Imac I got Lion operating system with iPhoto etc. for free. The initial setup worked 100% with no glitches. (On some of the finer things your forum was really helpful, thanks)

    The problems started when there was an available update for iPhoto :(

    - I first tried to run the update through the App store - the update started downloading, but kept on restarting after reaching about 10.4MB. After a couple of iterations the update would fail giving some Hash check error.
    - Then I tried downloading the update from the Apple website - When I tried running the download it informed me that all updates have to be done via the App store.
    - So I did the next logical thing and delete the whole iPhoto app, with the idea to do the installation for the program from scratch - No, this did not work either. I am now sitting without iPhoto and the download from the App store still bombs out.
    - The last thing I tried was removing any and all files related to iPhoto from the system. (the reasoning was that there might be some file that prevents the download from running). This did not help either. The App store shows that the program is available for download, but it keeps restarting the download after 10MB or so.

    Any other advice that you might give?
    Obviously without reinstalling the whole operating system...

  2. williamlamb13 macrumors newbie

    Nov 30, 2012
    iphoto deleted tried to reload no success

    AS per MGrobler 2 exact same issue. What happened was I was in iphoto and suddenly the screen went brown and the entire library disappeared. I tried EVERYTHING to get it back no joy. The pathetic part was that I was adding a photo from and email at the time nothing more or less.

    So.. in total frustration and with as usual no help from Apple, I deleted the app to rleoad it as I thought that might help.

    It will not reload from purchases on the app store. It says installing and gets to 10.2MB and then quits goes back to zero then does this four or five times and then tells me iphoto failed to load. Try again from purchases which is where i was downloading from duh!

  3. Big Stevie macrumors 6502a

    Big Stevie

    Jun 20, 2012
    Could you get to an Apple store and see the Genius Bar staff?
  4. MGrobler2 thread starter macrumors newbie

    Jan 1, 2012
    Problem solved itself


    I tried looking for a solution everywhere without any joy. My problem eventually sorted itself out.

    Still do not know what the actual problem was, but after an update on Lion operating system iPhoto correctly downloaded and installed again. Happened about 8 months ago, and never had the problem since.

    Good luck, try installing iPhoto again after a system upgrade.


Share This Page