iPhoto Videos in iMovie has incorrect dates??

Discussion in 'Mac Apps and Mac App Store' started by AeroBar, Sep 28, 2009.

  1. AeroBar macrumors 6502a

    Joined:
    Jan 21, 2009
    #1
    Hi,

    My iPhoto Videos are appearing in iMovie '09 with the wrong dates and times, but the dates and times in iPhoto are correct.

    Rather than adjust the info manually, is there a way of correcting it?

    Thanks
     
  2. AeroBar thread starter macrumors 6502a

    Joined:
    Jan 21, 2009
    #2
    Hi,

    anybody got any info on this?

    I adjusted a few "manually", but when I iMovie '09 opened a next it just went back to the incorrect dates.

    cheers.
     
  3. bkells macrumors newbie

    Joined:
    Jun 17, 2011
    Location:
    USA
    #3
    10 steps to correcting date in iMovie Events? will it work for you I don't know?

    1) Copy iMovie files to desktop
    2) Delete iMovie files
    3) Delete Cache folder AND Thumbnail folders in the desktop file you copied
    4) Use the program "A Better Finder Attributes" to perform date changes
    5) include subfolders and their contents if needed.
    6) go back to folder on desktop and CHANGE name of files. Be sure not to include any /,<>\|#$@*~! etc.... they really screw up iMovie, because the program has bugs. really not the best program, and I love macs........
    7) Then go to iMovie, go to file, create a new event, naturally it will come up as the present year.
    8) open your desktop folder and drag the individual .mov clips that are re-dated, re-named etc... into the new event with correct year.
    9) it should work, but if you included some bogus /\><$@# symbols in the name of your video, iMovie could freak out and create it's own "phantom" date for you. lovely right!!!
    10) all these steps just to make the date right on iMovie, we haven't actually got any work done yet, how depressing
    11) Good Night
    12) oh by the way, I have no idea what I'm doing, and no idea which of these steps is the one that worked, or why they worked, but in the end it worked! oh, wait, I didn't actually accomplish anything yet.......
     

Share This Page