Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

Patrick J

macrumors 65816
Original poster
Mar 12, 2009
Oporto, Portugal
When I try to enable this setting in iPhoto, I always get this error message.

I can enable Photostream on a Guest account. I have tried a new iPhoto library, Repairing permissions.

Any help would be very appreciated.


  • Log.jpg
    215.4 KB · Views: 133
  • Unable.jpg
    16.8 KB · Views: 96


macrumors newbie
Jun 30, 2012
FWIW I fixed mine when I realised I'd probably downloaded iPhoto using an AppleID from the App Store but logged into iCloud with a different AppleID. I deleted iPhoto and it's related files (but not the iPhoto Library) using CleanApp, entered the App Store with my usual AppleID and downloaded iPhoto again. Once the App Store, the downloaded iPhoto and iCloud logins were the same iPhoto Stream worked again.
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.