iPhoto won't complete import (iPhoto 08/Leopard)

Discussion in 'Mac Apps and Mac App Store' started by Cams, Nov 25, 2007.

  1. Cams macrumors regular

    Joined:
    Nov 7, 2006
    Location:
    Isle of Arran, UK
    #1
    This is the first day on my shiny new iMac 24 and it's really nice! But I have hit my first problem already. I copied my photos onto the iMac and then tried importing them into iPhoto. I'm running Leopard and iPhoto 08. My preference is not to have iPhoto copy the images, but I have tried both copying and not copying. It scans all the photos and I can watch it doing that until it has them all scanned. Then it gets to Finishing import... and never gets beyond that. I even left it running overnight, but it didn't work. The only thing I can do is force quit.

    Any ideas?

    I have a sneaky suspicion that I may be visiting these forums quite a lot in the coming weeks. I'm a switcher, dyed-in-the-wool Windows geek and have to expect some teething problems.

    Cheers
    Cams
     
  2. Cams thread starter macrumors regular

    Joined:
    Nov 7, 2006
    Location:
    Isle of Arran, UK
    #3
    Man, seems like it's a big problem. A lot of my pictures have indeed been meta tagged in Lightroom and I love Lightroom to bits. I figured I could import them quite happily into iPhoto on my shiny new iMac and I would enjoy the "it just works" Mac thing. I hit this obstacle on day one and have hit several others since. It's my second Mac - had my first for a year now -- and I'm still finding myself much more comfortable in XP. I am trying though, hence the iMac.
     
  3. beatledud macrumors 6502

    Joined:
    May 4, 2006
    #4
    Has anyone found the solution to this cause I'm still having this problem....
     

Share This Page