iphoto won't import photos

Discussion in 'Mac Apps and Mac App Store' started by leonofthewb, Jul 18, 2008.

  1. leonofthewb macrumors newbie

    Joined:
    Jul 18, 2008
    #1
    hello,
    sorry if this question has been posted before. I am currently running osx
    10.5.3 and iphoto 7.1.3. I am having difficulty importing photos from my camera (canon sd630). My older mac never had any issues. There are 2 problems. 1. Either the camera won't show up at all when i mount it or when i open iphoto. or 2. If the camera does mount, it refuses to import my photos and says that the files are not recognized. (they are jpgs)
    anyone else encounter this problem?
    i have never had any issues on my older iphoto and i successfully imported my old iphoto library to my new computer.

    thanks for the help...
     
  2. Taselcult macrumors newbie

    Joined:
    Jan 6, 2002
    Location:
    in the tubes
    #2
    Same deal here. I though it was an issue with my iphoto library so I created a new one and tried importing all my photos into it. Turns out photos that are able to be viewed in Preview won't go into iPhoto. Seems there all "unrecognizable". They're all different types (jpgs, raw, cs2, gif, etc) so doesn't seem to be any rhyme or reason. Anyone have a clue how to fix this? I can import from my camera (which previously would end up deleted if i modified the imported files in any way... part of the reason i moved to a new library). So only seems to be effecting these old photos.
     
  3. r.j.s Moderator emeritus

    r.j.s

    Joined:
    Mar 7, 2007
    Location:
    Texas
    #3
    What kind of memory card is in the camera?

    I know that some older cameras have trouble with cards 2GB and larger.
     
  4. Taselcult macrumors newbie

    Joined:
    Jan 6, 2002
    Location:
    in the tubes
    #4
    I'm guessing that your reply was to the original problem. Mine differences ever so slightly as all the photos I have that are giving me this error actually are files I exported from my previous iPhoto library. But the issue and result is the same. iPhoto refuses to acknowledge the photos as valid, even while Preview, Quicktime and everything else seem to be fine with them.
     
  5. SxySolja macrumors newbie

    Joined:
    May 31, 2011
    #5
    IPhoto won't import the rest of my photos from my camera!?

    I've had this macbook (10.5.8 OSX) for 2 years and have never had Iphoto (7.15) read 'Application Not Responding' when importing photos from my camera (FujiFilm J20) and same memory card (SanDisk) that I have also had for the past 3 years! I took 30 pictures/videos today on that same camera and same memory card and when I selected those ones to import, Iphoto would not respond- so I forced quit, reconnected camera, reopened and selected 4 at a time- worked perfect, until the last 8 photos! So I forced quit- reconnected camera, reopened and only selected 1 photo- same problem- app. not responding. I did all my software updates, restarted computer, and still same thing. ? These photos are very important to me- just as I'm sure every photo any one of us on here is trying to import, so It'd be nice if this problem can be fixed! Other than waiting and trying again in a couple days, or uninstalling it and reinstalling it (does anyone know if your photos save or erase completely during this operation?), anyone have any info or advice? It is not due to format of pic or video, I can try to import a same exact pic from my camera that is already in my library and I will get the 'app not responding' message. I have plenty of space on my computer and am not running any other programs when I am trying to finish the single import process that was working just fine! Thank you!
     

Share This Page