iphoto won't open (after trying to open a different library)

Discussion in 'Mac Apps and Mac App Store' started by gavstephenson, Mar 21, 2014.

  1. gavstephenson macrumors member

    Joined:
    May 25, 2006
    #1
    Ok, here is my problem,

    I attempted to downloaded (not sure that is the correct term) iPhoto from my back up onto my mother's mac mini (it's a long story why i did this). When I tried to open iPhoto it would not open - I've taken a screenshot of what the computer told me.

    Anyway, I gave up. But NOW! My mother can't open her iPhoto. she gets the same dialog box when she tries to open. We have restored iPhoto from her back up and the same thing keeps happening. Noooo! Please, please help, thank you.

    Of course, I will provide any information that will help.

    Thank you.

    Oh, I've tried holding down common option while opening the app. Nothing happens. Same story - it doesn't open and the dialog box pops up.
     

    Attached Files:

  2. gavstephenson thread starter macrumors member

    Joined:
    May 25, 2006
    #2
    oh my god! and now my mother's Mail app won't open. Same dialog box!

    What is going on?! could I have some kind of virus on my back up?

    Please help good people! Thank you!
     
  3. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #3
    It looks like you installed a version of iPhoto from your backup that is either too new or too old a version to run on the version of OS X she has.

    What version of OS X is she on? What kind of backup does she have and it it current? We might be able to just restore the whole system is she has a current Time Machine backup.
     

Share This Page