iPhoto won't start after re-install OSX

Discussion in 'Mac Apps and Mac App Store' started by Stormbringer, Feb 12, 2009.

  1. Stormbringer macrumors regular

    Joined:
    Jul 20, 2007
    #1
    I bought a new hard disk for my Macbook, installed it, installed OSX, and used Time Machine. Everything works great, just as it was earlier on my old hard drive. But, iPhoto '09 gives an error ("The application iPhoto quit unexpectedly") when starting up. The rest of iLife is working fine.

    So what could it be, and what can I do? I hope I don't lose the edited photos or my settings (I spent hours on Faces and Places...:() Anyone ideas?
     
  2. mrkgoo macrumors 65816

    Joined:
    Aug 18, 2005
    #2
    SO long as you don't touch your iPhoto Library folder (I assume you have iPhoto import photos rather than manage them yourself), your photos are most likely fine.

    I suggest the basic fixes - some suggestions to figure out what is going wrong, starting with the most basic and probably least harmful:

    1) Repair permissions. You never know, maybe your permissions for the file, the application, or something else is goofed up during install (did you change user name?). Open Applications/Utilities/Disk Utility - find Repair permissions click and try iPhoto.
    2) Trash your iPhoto preferences file - this is a file that contains setting for the software, such as view size, background colour, and other preference settings (such as what program you have as external editor, or whtehr you want colour profiles imbedded etc.). By trashing this file, you 'reset' your preferences for iPhoto. this file is found in <user>/Library/Preferences/ and is called com.apple.iphoto.plist or something. I suggest you don't actually delete it, but move it to your Desktop. When you next open iPhoto it write a new one with preferences all set. If that doesn't work, then your preference file is probably not the problem, so move your old back in and replace the newer one.
    3) Rebuild/Repair permissions on your iPhoto Library. It would be a good idea to have backups of your library incase this doesn't work. If you are extra worried, it may actually be safer to do the step 5 first. The iphoto library database keeps a record of where your photos are and what albums tehy belong to. This may be corrupt. You can rebuild it or repair the permissions by holding command+alt while you open iphoto. A menu should appear.
    4) From that same menu you can try the other options, such as rebuilding the thumbnails. These are small versions of the files kept for quick viewing. Maybe some are corrupted causing a crash.
    5) Reinstall iPhoto. Go back to your disk and reinstall iPhoto09. Could be messed up. In fact, this MAY be an early one to try - it will not harm your library.
     
  3. Stormbringer thread starter macrumors regular

    Joined:
    Jul 20, 2007
    #3
    Thanks a lot for your help! :)

    I have to disappoint you, the problem is solved a lot easier...:rolleyes: After re-installing OSX, I run the Software Updates program ones. I thought it would install all available updates, but it turned to be not that way. The second time I run it there were a lot of other 'new' updates. So there was the problem.

    But your help was not for nothing. ;) For example, I didn't know about that 'repairing permissions' and how to 'rebuild thumbnails'. And moving the prefs file is also a thing I didn't think of.

    So thanks again!
     
  4. mrkgoo macrumors 65816

    Joined:
    Aug 18, 2005
    #4
    Ah, so the OS wasn't as up to dat as required for iphoto09. Well it works now!
     

Share This Page