iPhoto won't start up after archive & install

Discussion in 'Mac Apps and Mac App Store' started by Nick G, May 3, 2010.

  1. Nick G macrumors member

    Joined:
    Oct 15, 2009
    #1
    Hi all.

    Recently I had to perform an archive & install after the System>Library>System Resources folder got trashed (I did this as it sometimes gets corrupted and cause the iMac to constantly wake from sleep. Previously it always restored itself, but not this last time.) My wife actually did the archive & install. We had been running Mac OS X 10.6.3, reverted back to 10.5.6 and then I upgraded back to 10.6 and then downloaded the combi update to 10.6.3 again.

    Well now when I try to launch iPhoto I get the following error report:

    Process: iPhoto [2788]
    Path: /Applications/Applications/iPhoto.app/Contents/MacOS/iPhoto
    Identifier: com.apple.iPhoto
    Version: ??? (???)
    Build Info: iPhotoProject-4240000~8
    Code Type: X86 (Native)
    Parent Process: launchd [77]

    Date/Time: 2010-05-03 15:54:39.922 +0100
    OS Version: Mac OS X 10.6.3 (10D578)
    Report Version: 6

    Interval Since Last Report: 102086 sec
    Crashes Since Last Report: 9
    Per-App Crashes Since Last Report: 9
    Anonymous UUID: CFC437A2-03C2-4AE8-A946-49A3640656B4

    Exception Type: EXC_BREAKPOINT (SIGTRAP)
    Exception Codes: 0x0000000000000002, 0x0000000000000000
    Crashed Thread: 0

    Dyld Error Message:
    Library not loaded: /System/Library/PrivateFrameworks/iLifeSlideshow.framework/Versions/A/iLifeSlideshow
    Referenced from: /Applications/Applications/iPhoto.app/Contents/MacOS/iPhoto
    Reason: image not found



    It looks like something is missing. Any ideas as to how to fix this?

    Also we now seem to have doubles of many Apple apps, originals that were saved from before the archive & install and new ones from reinstalling the OS. Perhaps this is related to the problems? The other apps I have tried so far seem OK though.

    Any help much appreciated.

    Regards,
    Nick.
     
  2. Gazmaz macrumors newbie

    Joined:
    Jun 2, 2010
    #2
    Apart from a few differences and I'm not sure I had to do the restore for exactly the same reasons but I'm getting the same Error when trying to open iPhoto.
    Looks like no one has any idea's at this stage, :( will post back if I find a way to fix iPhoto.
     
  3. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #3
    I don't see that either of you ran Software Update to pull down updates for iLife or iPhoto after the archive and install. Also, downgrading from 10.6 to 10.5.6 and then upgrading to 10.6 once again without first having updated to 10.5.8 likely didn't help either of your computer systems.

    Check if any of the other iLife applications like iDVD, iMovie, etc. are also failing to launch. If iPhoto is the only broken application, a reinstall of just that individual application is in order. For starters you are going to want to remove iPhoto from /Applications. Then go to /Library/Application Support and pull the iPhoto folder. Then navigate to /Library/Receipts, and junk any iPhoto*.pkg files within there. Finally, use the bundled applications install DVD, your iLife '08/'09 retail disc and customize the install to put just iPhoto back on the computer. Run software update and try relaunching.

    Left this for last, but OP, what led you to pull that folder? I have never heard of anyone needing to pull that folder to fix a sleep/wake issue...
     

Share This Page