iPhysics Levels and 1.1.3

Discussion in 'Jailbreaks and iOS Hacks' started by Kelly™, Feb 4, 2008.

  1. Kelly™ macrumors regular

    Joined:
    Jan 4, 2008
    #1
    Hello,
    I currently have a moded iPhone running 1.1.3 fully activated.

    I installed iPhysics from the iPhysics directory in Installer.app and ran the application, I saw the bar at the top, About and Setings buttons, nothing else but white.
    So I went back to Installer.app and installed a couple level packs including the Pinball and the Moon thing.
    Went back to iPhysics and it was the same, just white and the bar at the top.

    What am I missing?


    EDIT FOR FIX

    The best foolproof way to fix this problem is to install this repo.
    http://repo.tiny-code.com

    Go to the Tiny Code category and select the "iPhysics Level Fix for fw1.1.3", install it.
    This will bring all your current levels to life without moving anything on the filesystem.
    Whenever you add new levels, just go to Uninstall --> Tiny Code --> iPhysics Level Fix --> reinstall
    then your golden!


    FOR GEEKS
    The package in the above repo simply perform the following command at install and during each reinstall
    Code:
    chown -R mobile:mobile /private/var/root/Media/iPhysics
     
  2. meagain macrumors 68030

    Joined:
    Nov 18, 2006
    #2
    I only have Sandbox and Crayon showing yet I know I have more. I read something about ssh'ing in and changing permissions - but this failed for me.
    I'm also confused as to what path they should be in.

    iPhysics is worth hacking the phone in itself IMO and I miss my level packs.
     
  3. Midgetinabikini macrumors regular

    Joined:
    Aug 1, 2006
    #3
    how can i grab a shape in this...? every time i try it creates a line, only in the sendbox i can grab it.
     
  4. meagain macrumors 68030

    Joined:
    Nov 18, 2006
  5. Midgetinabikini macrumors regular

    Joined:
    Aug 1, 2006
    #5
    nope...just creating big ball...
     
  6. Kelly™ thread starter macrumors regular

    Joined:
    Jan 4, 2008
  7. Kelly™ thread starter macrumors regular

    Joined:
    Jan 4, 2008
    #7
    This is how to fix the missing levels in iPhysics when running 1.1.3 firmware.
    Fix, found at : http://www.ipodtouchfans.com/forums/showthread.php?t=32283
    {REQUIRED REGISTRATION}

    I did this and all the previously installed levels showed up perfectly.
    Other previously broken items work when doing this now as well.

    Using Installer.app make sure you have installed the BSD Subsystem and either OpenSSH or vterm.
    Don't care which, you just need to be able to perform linux command line actions.

    ok what you need to do is just create a symlink for library and media in root to the library and media in mobile

    This can not be undone, but it works 100% and doesn't mess anything up!

    open SSH (Putty, or any you want)
    Type In
    1. Code:
    Code:
      cp -R /private/var/root/Media /private/var/mobile/ 
    2. Code:
    Code:
      rm -r /private/var/root/Media 
    3. Code:
    Code:
      ln -s /private/var/mobile/Media /private/var/root/Media 
    NOW FOR LIBRARY
    4. Code:
    Code:
      cp -R /private/var/root/Library /private/var/mobile/ 
    5. Code:
    Code:
      rm -r /private/var/root/Library 
    6 Code:
    Code:
      ln -s /private/var/mobile/Library /private/var/root/Library 
    Then To Check If It Worked Type This
    1. Code:
    Code:
      cd /private/var/root 
    2. Code:
    Code:
      ls -la 
    IF THIS COMES UP THEN ITS GOOD
     Code:
     drwxrwxrwx    4 root  wheel     306 Jan 29 23:29 .
    drwxr-xr-x   18 root  wheel     680 Jan 29 03:04 ..
    -rw-r--r--    1 root  wheel    6148 Nov  3 20:41 .DS_Store
    drwxr-xr-x    6 root  wheel     306 Jan 28 22:42 .svn
    lrwxr-xr-x    1 root  wheel      27 Jan 29 14:42 Library -> /private/var/mobile/Library
    lrwxr-xr-x    1 root  wheel      25 Jan 29 23:29 Media -> /private/var/mobile/Media
    -rw-rw-rw-    1 root  wheel   18161 Jan 29 01:00 index.xml
    drwxrwxrwx    2 root  wheel     170 Jan 29 00:59 jailbreak
    -rwxrwxrwx    1 root  wheel  752965 Jan 28 22:30 root.zip 
    Sorry Omitted Some Lines
    1.Make sure you are running Installer 3.0

    [steps 2-4 not needed when running 3.0]

    5.Type In Code:
    Code:
      chmod 4755 /Applications/Installer.app/Installer 
    6.Type In Code:
    Code:
      chmod 755 /private/var/mobile/Media/iPhysics 
    7.Open Installer, Everything Should Work Beautifully.
    8. MUST RESET iPone!!

    READ THIS!
    You need to perform the following command using SSH or vterm after you install new levels to make them appear in the list.
    If you install a new program that is broken, try this as well, usually fixes.
    Code:
    chown -R mobile:mobile /private/var/mobile
     
  8. meagain macrumors 68030

    Joined:
    Nov 18, 2006
    #8
    :) The above scares me. I can't figure out what it's supposed to do. I.e.; I don't see anything above that just does this for iPhysics levels. I don't want to screw up my other working apps.

    There seems to be varying ideas on how to get the level packs to work. Varying ideas on what pathway/directory they should be in, and also if they should be 0777 or 0755. :(

    I tried both permissions numbers and it still doesn't work.
    I suspect it's my pathway. Mine are under:

    / private/var/root/media/iphysics/games/crayon physics/leveldata

    I assume this is incorrect?
     
  9. Kelly™ thread starter macrumors regular

    Joined:
    Jan 4, 2008
    #9
    Hey, they should be in that path, but substitute mobile for root /private/var/mbile/etc...

    My way just moves everything from root to mobile, and everything in the future going to root heads to mobile.
    Anything looking in root gets it because of the symlink to mobile.

    It's perfectly safe and works like a charm, nothing breaks.

    Trust me, you do it, your iPhysics will work dreamy, so will every other app.

    If you prefer, ill create a package and a repo somewhere that does this for you..
     
  10. Vex macrumors newbie

    Joined:
    Oct 29, 2007
    #10
    I would greatly appreciate it if you would do that.
     
  11. meagain macrumors 68030

    Joined:
    Nov 18, 2006
    #11
    So the correct path should be:

    / private/var/mobile/iphysics/games/crayon physics/leveldata

    ??

    All my other apps work fine so I'd rather not move them around. I just want to move the iPhysics level packs and am thinking of just manually moving those files where they'll work.
     
  12. Kelly™ thread starter macrumors regular

    Joined:
    Jan 4, 2008
    #12
    Yes, but after each install of new levels you need to perform this command.

    Code:
    chown -R mobile:mobile /private/var/mobile
    
     
  13. meagain macrumors 68030

    Joined:
    Nov 18, 2006
    #13
    Well, I moved iPhysics to that location and now 90% of my apps don't work. :)

    EDIT: My phone is dead. Can't reboot, can't SSH into it. It's toast. I'm going to have to restore and do everything all over again cuz I can't get it working. Yep - It's dead.
     
  14. Kelly™ thread starter macrumors regular

    Joined:
    Jan 4, 2008
    #14
    Ok, first of all, moving your iPhysics directory anywhere wont cause your phone to brick itself. So you did something stupid.

    Secondly, you could now just add http://repo.tiny-code.com to your sources in Installer 3.0 and then go to Tiny Code --> iPhysics Level Fix for 1.1.3
     
  15. meagain macrumors 68030

    Joined:
    Nov 18, 2006
    #15
    IDK - after I moved them the phone just was toast. I know it's not logical. I think despite me manually cleaning it up a few days ago, it got so convoluted with everyone's theories where things should go that it just couldn't deal with it. I couldn't even shut it off. I'm restoreing and starting with a clean slate. Almost on 1.1.3 again.

    Kelly - what method did you use to free up space on 1.1.3? BossTools or something else?
     
  16. Kelly™ thread starter macrumors regular

    Joined:
    Jan 4, 2008
    #16
    I used BossTools to move the fonts and ringtones to the other partition.
    After that I was fine.

    If "somehow" my method, which I mind you worked on all my friends iPhones, did indeed toast your phone I am truly sorry, it is very odd.

    Basically here is the problem with 1.1.3.
    In 1.1.2 and lower the iphone always used the "root" user for everything.
    In 1.1.3 they now use mobile to do stuff.
    Alot of the apps and iPhysics store their stuff in /private/var/root/Media with the root:wheel permissions.
    You can either send all the stuff to /var/mobile and make sure after installing new stuff or new levels you update the permissions back to mobile:mobile on the new stuff so the programs running as mobile, due to the change, can see it; or just reboot your iphone if you install my repo fix.
    Or you can simply change the permissions on certain things like the entire iPhysics directory to mobile:mobile so that when you launch iPhysics and it looks for the levels in /var/root/Media/iPhysics it can see then as the user mobile.
    The symbolic link method just ensures that new and old applications store their crap in the same place.
     
  17. Kelly™ thread starter macrumors regular

    Joined:
    Jan 4, 2008
    #17
    The fix it edited into the first post.

    Tested to work perfectly on 3 different iPhones and one ipod running 1.1.3.
     
  18. meagain macrumors 68030

    Joined:
    Nov 18, 2006
    #18
    I again moved my level packs to the appropriate directory. I changed Astrophysics to 0777. I couldn't change each file at once so I physically changed EACH file in Astro to 0777. Rebooted - still nothing.
    I again have all the level packs in 2 different sections without a way to easily delete them.

    What I again don't understand about the instructions here is that no where in them do I see anything related to iPhysics only. I don't want to move my other apps here because they work great. Plus I can't see a way in Fugu to delete the old files after they are copied to the proper area and I don't want a duplicate of all my apps in 2 places taking up space.
     
  19. meagain macrumors 68030

    Joined:
    Nov 18, 2006
    #19
    Over on Hackint0sh I'm reading a post saying the path should be:

    / private/var/mobile/media/iPhysics/Games/Crayon_Physics/LevelData

    Should it be in media or not? OK - I'm just deleting all my level packs & iphysics from everywhere and will contact the developer to see if he's working on a new version.
     
  20. meagain macrumors 68030

    Joined:
    Nov 18, 2006
    #20
    Kelly - your Tiny Code that you edited in in the top post works great and now I have my iPhysics back. Thank you
     
  21. arm2820 macrumors newbie

    Joined:
    Jan 27, 2008
    #21
    I've added the tiny code source to get the iphysics level fix but the source isn't showing up. anyone know why??
     
  22. DaffyDuck macrumors 6502

    Joined:
    Jun 18, 2007
    #22
    The tiny code source is gone. Kelly created it then posted a lie about working with Apple on the new SDK. The rumor spread around, he took down tinycode and admitted he made it up, some people got mad and the rest is history.
     
  23. meagain macrumors 68030

    Joined:
    Nov 18, 2006
    #23
    Doesn't work anymore. AlliPodHax source has an iPhysics fix but the last time I tried it - it didn't work either. That was a while ago though and I think it 'should' work.
     
  24. knoxtown macrumors 6502

    Joined:
    Nov 19, 2007
    Location:
    Everywhere
    #24
    What is this iPhysics? I downloaded it and played with some of the stuff....:confused: Am I missing something?
     
  25. Blax macrumors newbie

    Joined:
    Jun 27, 2007
    #25

Share This Page