iPlayer stopped working

Discussion in 'Mac Basics and Help' started by seasidebob, May 14, 2012.

  1. seasidebob macrumors newbie

    Joined:
    May 14, 2012
    #1
    I use iPlayer download to time shift TV and up to now (apart fro the short period when full screen didn't work) it's been fine on my MBA running Lion. Suddenly it stopped working - I can't see any of the programmes I've downloaded in the iPlayer desktop though I can still see the files in Movies/BBCiPlayer/repository, I can see library space is used in the Preferences and some of the titles if I right click on the iPlayer icon in the dock. In addition downloading no longer works. I've tried following the instructions here http://iplayerhelp.external.bbc.co.uk/help/downloading/desktop_mac tyo uninstall/reinstall iPlayer and Adobe Air but still no luck. Any ideas gratefully accepted. Thanks
     
  2. rbrian macrumors 6502a

    rbrian

    Joined:
    Jul 24, 2011
    Location:
    Aberdeen, Scotland
    #2
    I hadn't used it for a while, since that blank full screen bug started. I just loaded it up to check, and it's all working fine on my 2011 11" Air - full screen works too, so it must have been updated. Sorry I can't be more help, but at least it lets you know that there is something wrong at your end. Try creating a new User account, and downloading it fresh to see if it works there, then perhaps you can get a better idea of what exactly is wrong.
     
  3. hobanma macrumors newbie

    Joined:
    Jun 9, 2012
    #3
    Me too!

    Yesterday morning iPlayer was fine. In the afternoon, all of my content was gone even though the files still exist on my computer. I have a Mac Mini, a Win 7 laptop, and a Win 7 desktop. It's the same on all of them.

    I am in the USA and use hidemyass to connect through London. BBC will let me stream but iPlayer desktop is hosed. I've tried uninstalling iPlayer and Adobe Air, removing their folders. It still doesn't work.

    Does anyone have a solution to this problem? It's my only television.

    Thanks,

    Mark
     
  4. rbrian macrumors 6502a

    rbrian

    Joined:
    Jul 24, 2011
    Location:
    Aberdeen, Scotland
    #4
    Ah, so you're breaking the terms and conditions, and possibly also the law. Best quit while you're ahead.
     
  5. hobanma macrumors newbie

    Joined:
    Jun 9, 2012
    #5
    Gee thanks for the kind words. I'd gladly pay for a licence but I doubt that the signal would reach across the Atlantic.
     
  6. chrisw1944 macrumors newbie

    Joined:
    Jun 10, 2012
    #6
    Mee too

    Iplayer stopped working 2 days ago similar to seaside bob. Reinstallation does not help. This is obviously not a personal problem. Am using Mac air 10.7.4.
    Can anyone help
     
  7. urbanbeaver macrumors newbie

    Joined:
    Jun 14, 2012
    #7
    May have a solution

    - My problem sounds exactly the same as seasidebob. UK use only. Had been working fine then suddenly programmes disappeared and download no longer worked.
    - Tried various things on the bulletin boards including reinstalling iPlayer, although I didn't delete the files left in the repository as the programmes were no longer available for download and I still wanted to watch them.
    - Found that most of the programmes in the repository could be seen and played by ctrl clicking the icon in the tray except for the last one I had been watching which I knew was out of time in any case. It was a bit finicky though and if you manually deleted the folders after watching the programmes the whole list could disappear until they were put back. iPlayer is sensitive to what is in the repository it seems. Also the computer had to be restarted between watching programmes.
    - At one point I manually deleted the folder for the last file I had been watching before the problems arose. All the other programmes were now available to watch and download was working again. Noticed that the seven day timer had been started on the programmes I had watched using ctrl click. Everything fine now.
    - This could be a complete co-incidence but I would suggest going into Finder, then to Movies/BBC iPlayer/repository, then find the folder belonging to the last thing you were watching. You should be able to identify it from the jpeg in the folder. Delete that folder.
     
  8. victory4nelson macrumors newbie

    Joined:
    Jun 23, 2012
    #8
    UrbanBeaver that worked perfectly, had the same problem for some time and was about to give up on it.Thanks
     

Share This Page