iPod touch iPod 4G Randomly boots into Safe Mode

gigahertz

macrumors newbie
Original poster
Jun 11, 2013
7
0
Sorry if this in the wrong forums, I new here :p

So my iPod has been randomly since Friday. On Friday, I installed:

AltKeyboard
AutoProtect for iOS 6
SwipeSelection
BatteryBanner? (think that is what is called)
And that tweak that hides your keyboard with a space bar swipe

Since then I've uninstalled those tweaks, but I still boot into safe mode...

These are the tweaks and themes I had before installing the above tweaks (and have now):

iFile
iCleaner
Activator
StatusBar
Springtomize 2
NCSettings
Winterboard with:
LS Thin
LS RisingBars
LS Typo5
Ambriel
FlatIcons
Ayecon

And to be honest, part of me thinks the Safe Mode booting started after installing RetroArch (gone now), but I can't remember.

Any help?

Thanks in advance!

PS. this iPod is on 6.1.2 jailbroken with Evasion
 
Last edited:

BumpyFlatline

macrumors 68030
Apr 11, 2012
2,668
0
There's a recurring tip that is mentioned in every single "please help, my phone is crashing" thread. That tip is, disable all mobile substrate addons with sbsettings or iCleaner Pro and then slowly turn them on one by one or in bunches. Do this very slowly so when the crashing starts, you'll know it was the most recent MS addon that is causing it. From there you can determine if its only that MS addon or if its conflicting with another MS addon. It may seem tedious but it almost never fails.

This is the best way to resolve your crashing. FYI if you read even one other thread regarding this topic you would have learned this. The good news is, you don't have a ton of stuff installed so it shouldn't be too difficult to narrow down the offending tweak. Do this and then report back. Let us know if you have any questions or problems. Keep me posted! Good luck.
 

gigahertz

macrumors newbie
Original poster
Jun 11, 2013
7
0
Can I disable them using springtomize 2, or would it be better using the options you mentioned?
 
Last edited:

darricksailo

macrumors 601
Dec 18, 2012
4,354
113
Can I disable them using springtomize 2, or would it be better using the options you mentioned?
if you still have the springtomize 2 version where you can disable mobilesubstrate tweaks, then you can use that instead of SBSettings or iCleaner Pro
 

gigahertz

macrumors newbie
Original poster
Jun 11, 2013
7
0
It would appear that Winterboard is causing the crashing, which is weird because it worked fine before.
 

Troneas

macrumors 65816
Oct 26, 2011
1,378
54
At the alternatives section.
it doesnt help the fact that you fail to mention when it crashes. and how often. does it crash when your phone is idle? in the lock screen? home screen?


in any event i had a very peculiar random crash in my lock screen when the phone was idle and it occurred every two or three days. first i removed the latest installed tweaks but that didnt help. also, they were all mainstream widely used tweaks and people didnt seem to suffer from that problem. to add more mystery to this, another idevice i own has the same exact tweaks (except for the themes) and it was working fine.


how did i solve this?

ILEX RAT. Complete restore and i manually re-installed the same tweaks one by one, cleaning out the old cache in the process.


no more problems for me. i thus have to assume it was something left over from the past or something along the way became corrupt.
 

gigahertz

macrumors newbie
Original poster
Jun 11, 2013
7
0
it doesnt help the fact that you fail to mention when it crashes. and how often. does it crash when your phone is idle? in the lock screen? home screen?


in any event i had a very peculiar random crash in my lock screen when the phone was idle and it occurred every two or three days. first i removed the latest installed tweaks but that didnt help. also, they were all mainstream widely used tweaks and people didnt seem to suffer from that problem. to add more mystery to this, another idevice i own has the same exact tweaks (except for the themes) and it was working fine.


how did i solve this?

ILEX RAT. Complete restore and i manually re-installed the same tweaks one by one, cleaning out the old cache in the process.


no more problems for me. i thus have to assume it was something left over from the past or something along the way became corrupt.
I said randomly in the first post, so anywhere.

I can't restore and re-jailbreak anyway, I don't want to update to 6.1.3, and I don't have SSH Blobs to restore to 6.1.2.


Actually I just googled iLexRat, might try it.
 
Last edited:

iRetired

macrumors 6502a
Apr 21, 2012
626
104
WNY
I haven't heard of anyone losing jailbreak after using iLex rat. But if you're using Gridlock 2, be forewarned that ILR does NOT remove it.
 

gigahertz

macrumors newbie
Original poster
Jun 11, 2013
7
0
Been a while since last post.

Since restoring my iPod with ILEX Rat, I reinstalled all of my teaks I have before. This was working fine until 2 days again, where I randomly booted into Safe Mode, and now it happens more times than before ILEX Rat.

I don't know what to do now.
 

BumpyFlatline

macrumors 68030
Apr 11, 2012
2,668
0
Been a while since last post.

Since restoring my iPod with ILEX Rat, I reinstalled all of my teaks I have before. This was working fine until 2 days again, where I randomly booted into Safe Mode, and now it happens more times than before ILEX Rat.

I don't know what to do now.
Don't install all the tweaks you had before wiping it. Obviously something is conflicting with another tweak or you installed a bad tweak, but whatever is causing it, you just need to disable all your tweaks and then re- enable them a few at a time until the crashes start up. Once they start happening aim, you'll know its related to the most recently enabled tweaks and you'll find your culprit. Should be pretty easy and straightforward to figure out. Good luck.

Edit: I just realized I already posted this info way back when you first started the thread. Regardless, I suggest doing this again. If it starts crashing after enabling winterboard then my guess is that something is conflicting with winterboard. Winterboard doesn't usually cause crashes unless you use theme that might have a bug. I think you should start this process with winterboard enabled and everything else off. Then slowly start enabling them until the crashes start. When they start, you'll know the most recent tweak is conflicting with winterboard. Remove that offending tweak, turn everything else back on, and enjoy your device. This is what I would do.
 
Last edited: