"IPOD" app on iphone 4 doesnt open (white screen)

Discussion in 'iPhone Tips, Help and Troubleshooting' started by yattaze, Feb 6, 2011.

  1. yattaze macrumors newbie

    Joined:
    Feb 6, 2011
    #1
    ok so i have been struggling for 2 days now!
    I checked over 5 different apple related forums and couldn't find any answers so can anyone on here help me please?

    Basically my "IPOD" app on my iphone 4 doesn't open, every time i click on the app the screen goes white for about 8seconds and exit on its own.

    So I deleted all my music and videos using itunes and the app started to work, and when i re-added my songs the app doesn't open again??
    I turned my phone off and on, synced it on itunes but still no results.

    This never happened to me before, My iphone is jailbroken (4.0.2) i used Limera1n but that shouldn't be causing the problem.
    I don't want to restore it itunes will update the firmware o_o
     
  2. JamesMB macrumors 68000

    JamesMB

    Joined:
    Jan 2, 2011
    Location:
    Texas
    #2
    Could it be that just one of your songs or playlists is causing the problem?
    Try adding your music back, a few songs at a time, in one new playlist.
     
  3. yattaze thread starter macrumors newbie

    Joined:
    Feb 6, 2011
    #3
    Hey, thanks for the reply ^^

    OK so i tried adding one song at a time and it seems to work, but when i tried adding an album it started to play funny again :(
    Again it opens to a white screen and closes after 8 seconds......

    So does this mean i cant add albums again?
    I really don't want to restore and update the firmware... un-jailbroken iphone would be boring and useless to me lol

    Hmmmm this so messed up what could be causing it?
    I didn't update my music library for a week or 2 and it just suddenly stopped opening 2 days ago :confused:
     
  4. JamesMB macrumors 68000

    JamesMB

    Joined:
    Jan 2, 2011
    Location:
    Texas
    #4
    Your guess would be as good as mine!
    I finally got tired of the hassle, I just run stock now. It just wasn't worth the trade off to me.
     
  5. yattaze thread starter macrumors newbie

    Joined:
    Feb 6, 2011
    #5
    Hey thanks alot for your help James ^^
    I decided to restore the phone and update it, as long as i have whatss app, av player and my music i can survive lol.

    Also i can use Greenpoison to jailbreak 4.2 so all seems well haha
    Thank again.:)
     
  6. JamesMB macrumors 68000

    JamesMB

    Joined:
    Jan 2, 2011
    Location:
    Texas
  7. windrose macrumors newbie

    Joined:
    Nov 29, 2011
    #7
    Check your Settings

    I also had a problem after sync'ing my iPhone. When I pressed the
    Music app, I would get a white screen. It would last about 8 seconds
    and then return to the home screen. Possibly I had tripped a software
    bug. I tried rebooting the phone with the usual method, but it didn't
    help. Finally, I went to the Settings app on the iPhone and selected
    the "Music" menu item. It showed about half a dozen items that could
    be toggled on and off. When I toggled "Group By Album Artist", this
    seemed to make everything start working again. Hope this helps someone.
     

Share This Page