ipod classic stuck on "connected - eject before disconnecting"

Discussion in 'iPod' started by hhfanx2, Sep 28, 2010.

  1. hhfanx2 macrumors newbie

    Sep 28, 2010

    I hope someone can help me with my new-ish ipod Classic (bought earlier in September). It had been fine until now...

    But today, I tried to sync it. I had itunes open, I connected the ipod, and waited. The screen showed the "Connected - Eject before disconnecting" screen, but the device did not appear in itunes.
    Flailing randomly, I went to the apple site support and tried following the "Update Driver Software" (haha, I don't know - it looked like it might be relevant?). But it didn't help. I also updated itunes. Didn't help.
    The ipod is not even showing up as a a usb drive or anything when I go to "Computer" to check my drives.
    Finally, itunes had 'recognized' my ipod and is telling me it was corrupted or something, and so I started to restore it, etc. But now the progress bar is stuck on "Downloading 1 item - iPod Software Update" and itunes appears to be frozen (it's been this way for at least 10 minutes now).
    So now the ipod is still stuck on "Connected - eject before disconnecting" and won't turn off either. I'm keeping itunes on, hoping that the "restore" process will end up working, but my hopes are not high.

    Can anyone help? Thanks so much, in advance.
  2. Matt.H macrumors member

    Feb 1, 2009
    To get your iPod back to normal I would suggest resetting it, by toggling the hold switch back and forth, and then hold both the "Menu" and "Select" buttons until the screen goes off, and the Apple logo appears on the screen.

    Failing that, check out the 5 R's on the Apple website to try and reset your iPod.

    Once you've got your iPod sorted, it would be worth rebooting your computer, and trying again.

    Hope that helps!

Share This Page