Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

TruthWatcher412

macrumors 6502a
Original poster
Sep 15, 2011
735
787
Pittsburgh, PA
I have an iPod Classic, latest gen, 160 GB.

iTunes doesn't recognize my iPod for some reason. It shows on my Mac desktop, on the iPod screen it says 'Connected, Eject before disconnecting,' and my iPhone is showing separately in iTunes via Wifi, but my iPod classic (latest gen) won't show up. The only thing that has changed on my computer since my iPod last showed up in iTunes is that I installed the OS X NTP Security Update through the Mac Store, not saying that's what is causing it but that's the only thing that's changed. I haven't installed any other applications or made any changes to my Mac at all. I can successfully eject my Classic by double tapping to get the dropdown menu and choosing to eject, and it says "Ok to disconnect" on the iPod screen just as if I did it from iTunes.

I also tried following steps at this link, but still have the same problem.
 

BrettApple

macrumors 65816
Apr 3, 2010
1,137
483
Heart of the midwest
Just to check, you wouldn't happen to be on OS X 10.10.2 beta would you? I was on the beta release and it broke iTunes completely for my iPod classic (latest), iPod video, and iPod touch. All could be seen everywhere else but iTunes.

I finally just went back to Mavericks, and I'm enjoying the stability. But I won't go into that.
 

TruthWatcher412

macrumors 6502a
Original poster
Sep 15, 2011
735
787
Pittsburgh, PA
Just to check, you wouldn't happen to be on OS X 10.10.2 beta would you? I was on the beta release and it broke iTunes completely for my iPod classic (latest), iPod video, and iPod touch. All could be seen everywhere else but iTunes.

I finally just went back to Mavericks, and I'm enjoying the stability. But I won't go into that.

Yes, I am on 10.10.2. I didn't think about submitting a feedback assistant bug to Apple, I'll do that if it does any good. Maybe that's what's causing it but I thought I installed 10.10.2 and it was still working after that until that security update. I haven't had any other issues.

I tried with my iPod Touch, 2nd gen 32GB just now and it does show up in iTunes. My iPhone also shows up.
 
Last edited:
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.