iPod nano not detected on PowerMac G5 (USB2)

Discussion in 'iPod' started by vd0t, Nov 26, 2005.

  1. vd0t macrumors regular

    Jun 7, 2005
    I have a very odd problem..
    My PowerMac G5 (the original 1.8GHz) does not recognize my iPod nano on the rear or front USB2 ports. Sometimes it has the Do No Disconnect screen on the iPod, sometimes not. But it does charge the iPod. At first I thought it was the iPod itself (it was a replacement model Apple sent me) but I tried it on an iMac and my Dell laptop and it works fine (that's how I'm transferring my music temporarily). My original iPod nano (that I sent out for repair) worked flawlessly on my PowerMac. After a lot of trial and error, I found that it worked when I connect it to my 20" Cinema Display (the original one, not the newer one). However it is only USB1 and it would be a pain in the ass to use.

    So then I thought it was my USB2 ports that were problematic. However, all of my USB devices work fine.. external USB2/firewire drive, thumbdrive, laser printer and my phone (which acts like a thumbdrive when connected to a computer, also charges via USB).

    Things I've tried so far..
    - connected my iPod mini
    - connected another/different iPod nano
    - deleted iTunes and iPod updater and re-installed again
    - Archived and install and updated to 10.4.3
    - re-installed fresh copy of Mac OS X (currently running 10.4.3) - which I really thought would fix it if it was a software issue
    - unplugged all devices except iPod
    - unplugged my PowerMac from wall socket for 15 minutes
    - reset Open Firmare (reset-nvram, reset-all)
    - command-option-p-r

    Then I thought my USB might be fried (but why then would it work for everything else).

    My latest theory is that there isn't enough power going through the USB to my iPod (although it does charge it, and also charges my phone). Can't think of anything else to do!

    Edit: When I connect my iPod mini using the firewire cable that comes with it, it works fine. So it seems to be a USB issue.
  2. vd0t thread starter macrumors regular

    Jun 7, 2005
    I should also add, that it does see the iPod in the System Profiler, when I select USB.
    Although sometimes when the iPod is connected, upon clicking USB in System Profiler, System Profiler would just freeze. iTunes and the iPod updater would not launch either. So for some strange reason, it knows that an iPod is connected (it freezes as a response). When my iPod is not connected, it works fine.

    Please help!
    Do you think Apple would help me (my Mac for sure is out of warranty though)?
  3. vd0t thread starter macrumors regular

    Jun 7, 2005
  4. vd0t thread starter macrumors regular

    Jun 7, 2005
    It works!

    Just to update.. I was really frustrated last week cuz my damn nano wouldn't work on USB2.

    So today I did the following..
    1. Erased the iPod using Disk Utility
    2. Restored using iPod Updater (2005-09-23, not the latest.. if it makes any difference)
    3. Booted up using the Mac OS X 10.4 installer DVD
    4. Repaired my main hard drive
    5. Connected my iPod to USB2 and booted back to Mac OS X and it works!.. currently updating!
    6. No step six :)

    (Oh. I also installed the latest Security Update before doing any of those.. but I really doubt it was because of that).

    Anyways, just wanted to post for those who are experiencing similar issues.. it's a pain in the ass to say the least. I'm not too surprised that nobody posted anything.. I probably did everything anyone would have suggested!

    Edit: typo
  5. vd0t thread starter macrumors regular

    Jun 7, 2005
    I think I spoke too soon.. after a couple of restarts.. it's not working anymore :mad:

    Something is definitely wrong.. what I can't seem to figure out is if it's a hardware issue (my Mac? or my iPod?) or a software issue.
  6. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    So the iPod mini worked properly through the same port? Can Disk Utility see the iPod or not?

    Considering you reinstalled the system and assuming the mini worker properly, I think it's reasonably safe to say it's an iPod issue. I think this is a job for Steve and his band of merry Geniuses in the land of AppleCare.
  7. vd0t thread starter macrumors regular

    Jun 7, 2005
    iPod mini works via Firewire (not on USB2). It seems to be a USB related issue.

    Disk Utility can only see it when iTunes sees it as well. In other words, if it doesn't mount on my desktop and syncs with iTunes, then Disk Utility doesn't see it either. However, it sometimes still has the Do Not Disconnect sign (sometimes not).

    Oh.. I should also point out though.. that everything works perfectly fine when I connect it to the USB 1.1 port of my Cinema Display. So to me that kinda eliminates the iPod as the problem (unless it is a USB2 specific problem.. but again, it works fine on the USB2 of the iMac!!)... I just don't get it!!!!!!!!!

    Edit: Is it possible that the issue lies in the USB2 port of my Mac.. and that it somehow it will no longer work with iPods (but works fine with everything else)?
  8. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    Ignore my earlier posts because I started making assumptions that are wrong.

    I've heard of it not working on the front USB ports of Power Macs, from memory it was a power issue. However, I haven't heard of it not working on the rear ports. I think it seems pretty conclusive that it's a problem with your Mac though.

    Maybe insert the Hardware Test CD that came in the Power Mac box and start from it (hold down C on start up) to see if it can find or fix any problems. Also, an SMU reset may help. :)
  9. vd0t thread starter macrumors regular

    Jun 7, 2005
    mad jew.. thanks for your reply.

    I think it may have something to do with the USB2 port on my Mac as well. But what still remains a mystery to me is why everything else works (and the fact that my original iPod nano worked flawlessly a couple months prior). I've only experienced this issue when I got my replacement nano.
  10. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    So, have you run the test CD? Post what it comes up with. :)
  11. vd0t thread starter macrumors regular

    Jun 7, 2005
    Yea I did.. it passed everything (including Logic Board.. which is where the USB ports are located).

    I did some more troubleshooting as well.. I fired up my Tiger install DVD.. and ran Disk Utility (repair disk) on my nano.. here are my results:
    - It ALWAYS detects the nano.. I've ran the test about 15-20 times (lots of time wasted :mad: )
    - When the nano is connected via the USB2 found on the rear of the PowerMac.. it sometimes (but not always) freezes Disk Utility
    - If it doesn't freeze, I'd run repair again and after a few times, it WILL eventually freeze Disk Utility.. forcing me to shut down my computer manually and restart
    - When the nano is connected to the USB1.1 on my Cinema Display.. Disk Utility always runs through and NEVER freezes.

    I can safely conclude that it is NOT a software issue (since I'm running Disk Utility from the install DVD). So is it the nano or my Mac? I still don't know.. but hopefully it's the nano.. seeing as I can still get it replaced.

    I will try to do the same tests on another nano. If I get the same results, then it's the Mac, if everything runs well, then it's the nano.

    ... sooo very frustrated :mad:

    Edit: I can say the problem is not the cable either as I've always tried it with a known working cable with the same results.

Share This Page