ipod nano not recognised by mac

Discussion in 'iPod' started by emilysa87, Sep 20, 2010.

  1. emilysa87 macrumors newbie

    Joined:
    Sep 20, 2010
    #1
    Hey, I need some help.... I have an ipod nano which I connected to my mac and everything was fine until I took the ipod to work. I connected my ipod to my work computer (windows) to charge it, but it wiped all my songs and now when I connect it to my mac it isn't recognised. An icon comes up but instead of saying 'ipod' it says 'no name', itunes opens but it doesn't recognise the ipod as a device. I've tried resetting the ipod and I've uninstalled and reinstalled itunes. I've tried everything on the apple website but nothing seems to work. I'd really appreciate your help guys!!

    Thanks, Emily
     
  2. auldain macrumors newbie

    Joined:
    Sep 29, 2008
    #2
    I have the exact same problem. Did you ever get an answer and resolved this problem. Thanks.
     
  3. kaielement macrumors 65816

    Joined:
    Dec 16, 2010
    #3
    Two things I think happened here. First I think the auto update option was checked. When it gets plugged into a computer that is not it's native library It will wipe the iPod thinking you are going to update it using the new library not a windows or mac issue but more a settings issue. I always have all my iPods, iPhones, and iPads set to manually manage all my music. I constantly have my phone plugged into my buddies computer to charge it. Secondly what I think also happen is that the iPod reformatted itself for windows. I would see if you can on your mac reformat the iPod and see if that works. If all else fails take it to an apple store. They may be able to help you if you feel completely lost and you don't think you are very tech savvy. Hope this helps
     

Share This Page